Librem 15v4 Temperature

I have two Librem 15v4s. The only difference in the hardware is one has a larger SSD and more RAM. The other difference is is coreboot + SeaBIOS and the other is PureBoot; the PureBoot one I just bought recently. I’ve noticed that they have very different temperature readings when at rest:

Recent laptop:

$ sensors
Adapter: Virtual device
temp1:        +43.5°C

Adapter: ISA adapter
Package id 0:  +50.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +47.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +47.0°C  (high = +100.0°C, crit = +100.0°C)

EDIT: I don’t believe I’ve seen this drop below 40 yet.

Older laptop:

$ sensors
Adapter: Virtual device
temp1:        +30.0°C  

Adapter: ACPI interface
in0:          12.41 V  
curr1:       850.00 mA 

Adapter: ISA adapter
Package id 0:  +34.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +33.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +32.0°C  (high = +100.0°C, crit = +100.0°C)

This causes significantly more fan usage on the newer laptop. The fan picks up whenever using the browser, while the other does not.

I’m trying to figure out why this is and if there is anything I can do about it. Does anyone have experience here? I can provide more command output if necessary.

I take your point about the fan usage. It would probably bug me - but those temperatures are not as such something to worry about.

Do you feel like “fault” isolating?

With care you could try to narrow down the difference e.g. temporarily flash coreboot in the newer one and e.g. take out / swap over the SSDs.

Is it the case that you bought both units new?

Yes, I’m mostly just bugged by the fan turning on so often when doing simple tasks.

I did buy both of them new. I could try to do the changes you recommend and see where the difference is, but I’d like to reach out here and see if anyone from Purism or the community has already seen this issue and has ideas on fixing it.

1 Like

you could always flash the Pureboot one to coreboot, just to rule out the firmware. After that, I’d probably try cleaning/applying fresh thermal grease in case it was a manufacturing issue there

1 Like

I flashed the coreboot + SeaBIOS firmware and also put in a similar 250GB SSD. The temperatures still seem to be hovering around 10 degrees higher on average.

I’m not sure where to even check for issues with thermal grease without a bit more time looking around on the motherboard. I don’t suppose you’d have a picture? I’ll try to take a look at that later when I have time.

One other thing … you described the hardware differences but what about software differences or settings differences?

To rule that out, are you in a position to do a Live Boot on each? The point of that is that they will then each be running the same version of the same software, and not running anything extra that you may have installed, and should have the same settings.

I haven’t ruled out software yet, no. I was focused mostly on a potential firmware issue after doing some searches on this forum. I did swap hard drives and noticed that the one that is hotter was also hotter on the other hardware, so I am leaning in that direction now. The biggest software difference is probably the kernel version and some tweaks I forget I made. Gonna try swapping the kernel and seeing if that does anything.

fwiw here (15v4 + coreboot + SeaBIOS, running GNOME with tilix, two instances of firefox, and dosbox)

Adapter: Virtual device
temp1:        +34.5°C  

I don’t think I ever got it above 40 degrees.

Edit: oh, I got it to +48 while compiling a C++ project with -j4 while running all the other things

Don’t suppose you could share your kernel version? uname -r ? I just built 5.8.0 using the config from the original PureOS kernel and it seems to be doing better.

Actually I think the kernel upgrade fixed it completely.

1 Like

Glad to hear the kernel upgrade solved it, this is the one I use (from PureOS byzantium):

$ uname -r