Librem 5 and Crowdsec

Hi
I am thinking to install the Crowdsec app onto my Librem 5.
Has anyone done a Crowdsec install and if so what Bouncer is good to use.
Thanks for any info.

more info from Crowdsec site.
Outnumbering cybercriminals all together
Gain crowd-sourced protection against malicious IPs. Benefit from the most accurate CTI in the world.

Regards
Frank

1 Like

Tried to install Crowdsec, but failed. I think PureOs is not supported.
Got the response below.

purism@pureos:~$ curl -s https://packagecloud.io/install/repositories/crowdsec/crowdsec/script.deb.sh | sudo bash
Detected operating system as PureOS/byzantium.
Checking for curl…
Detected curl…
Checking for gpg…
Detected gpg…
Detected apt version as 2.2.4
Running apt-get update… done.
Installing apt-transport-https… done.
Installing /etc/apt/sources.list.d/crowdsec_crowdsec.list…curl: (22) The requested URL returned error: 404

Unable to download repo config from: https://packagecloud.io/install/repositories/crowdsec/crowdsec/config_file.list?os=PureOS&dist=byzantium&source=script

This usually happens if your operating system is not supported by
packagecloud.io, or this script’s OS detection failed.
You can find a list of supported OSes and distributions on our website: https://packagecloud.io/docs#os_distro_version

Ay, PureOS may not be recognized as a distro to add a repo, but the bigger problem to me seems to be that https://packagecloud.io/app/crowdsec/crowdsec/search?dist=&filter=all&page=3&q=aarch lists aarch64 (as in, compatible with L5 architecture) only for rpm packages, not dep. Contact Crowdsec to hear if they would be willing to update and include PureOS with aarch64. Of course, you could try using https://github.com/crowdsecurity/crowdsec and make from source.

Edit: for anyone interested, intro to Crowdsec: (“CrowdSec is not a SIEM, storing your logs (neither locally nor remotely). Your data are analyzed locally and forgotten.
Signals sent to the curation platform are limited to the very strict minimum: IP, Scenario, Timestamp. They are only used to allow the system to spot new rogue IPs, and rule out false positives or poisoning attempts.”). Also: https://docs.crowdsec.net/docs/intro/

1 Like

Thank you. I dont have the skill to install from source.
After further investigation, I determined I cannot afford the charges, even if Crowdsec was configured for PureOS as a deb install.
So now I am trying to figure out how to remove what I installed.
I found the below so I am going to try
apt-get remove --purge crowdsec

Well, I figured this out on my own. Something is up with the installation/removal process. You cannot do an “apt remove crowdsec” since it left files in place which I think broke this.
The result of the above is that I needed to manually remove all crowdsec folders and files myself because apt did not do that. Once I did that, I was able to install it properly.
Advice to crowdsec team: Review your “apt remove” code to ensure that it actually removes all the crowdsec files.

In the future apt-get remove --purge XXXX can be handy as it as well removes the configuration files etc (we ensured it’s working as expected in crowdsec’s case).

apologies for the bold typing, not sure how it happened.
I did the purge, seems to have worked.
purism@pureos:~$ sudo apt-get remove --purge crowdsec
[sudo] password for purism:
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
The following packages will be REMOVED:
crowdsec*
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
After this operation, 38.2 MB disk space will be freed.
Do you want to continue? [Y/n] Y
(Reading database … 96140 files and directories currently installed.)
Removing crowdsec (1.0.9-2) …
(Reading database … 95989 files and directories currently installed.)
Purging configuration files for crowdsec (1.0.9-2) …
purism@pureos:~$