Librem 5 bricked after initial update

I’ve finally received Librem 5! It booted up, I would updated, rebooted and it was installing in progress. I have plugged it for charging while installing as the battery was ~15%. The phone did not boot, so I left it overnight charging - red charging light was on. At morning phone would not boot up. I have followed on how to enable charging pulled out battery led flashing light etc. The left it charging for another 4 hours. The phone would still not boot up. Now charging light won’t come up when USB cable inserted unless pull battery and following procedure again. Then red light is on when charging. Where to go from here - hours of charging, light still red, no booting.

Maybe pressing the power button for a certain number of seconds can help. Note that holding the power button for 5 seconds and then releasing it can have a different effect compared to holding it for 20 seconds and then releasing it.

See also this other thread, maybe some of the hints from there can help:


Yes that worked, thank you.

What was it specifically that worked in your case? Was it holding down the power button for a certain time, and if so, how many seconds?