Librem 5 BT: change operating mode

Hi! I noticed recently that the bluetooth of my Librem 5 does not find bluetooth 5 devices anymore (my mi band 4 for example).

dmesg reports:

redpine_91x: FW Version  :
redpine_91x: RSI FW Version      :  0000.
redpine_91x: Driver Version      : RS9116.NB0.NL.GNU.LNX.OSD.
redpine_91x: Operating mode      : 5 [Wi-Fi STA + BT EDR]

I saw elsewhere on the forum and here or here that the Operating mode should be 13 (Wi-Fi STA + BT DUAL). Anybody knows why mine shows 5 and how to set a different mode?
I could not find this info anywhere.

(I’m on Byzantium)


1 Like

Mine shows the same

Thanks, according to this (table at page 9), Mode 5 does not use BT LE. Do you have a BT LE device you can test your L5 with (to see if it appears in the device scan)?



Bluetooth not found but service runs no default controller

1 Like

Thanks, this worked (it switched the operating mode to 13), but then I had the same problem of the OP in the other thread. Bluetooth just did not work (it was seen by rfkill, but nothing more). I had to revert back to mode 5 now.

Ah I see now that
“Firmware vesion 2.0.0024 broke BLE so we need to disable dual bluetooth support”
I asked on the gitlab issue whether it will ever be supported again