Librem 5 Cellular Modem and VoLTE Assistance

Hello All, I am reaching our for some help with my Librem 5 Cellular modem. Hopefully someone in this great community can point me in the right direction.

I have recently started using my Librem 5 after It had sat collecting dust for a few months. It was working great for about 3 weeks and then It suddenly stopped making or receiving calls. This is due to by mobile carrier switching off their 3G service (Vodafone, NSW, Australia).

SMS messaging and Cellular Data still work, but calls do not. As far as I can gather, this is because of an issue with VoLTE. From research I have done the Librem 5 modem has the frequency bands that should allow VoLTE on my network. I have also found some information about enabling and disabling VoLTE on Librem 5 Here but this seemed to make no difference.

I have the same issue with a pinephone and was able to make some progress there by upgrading the modem firmware. I had been using the open firmware 0.7.4 and upgraded to the latest of the proprietary firmware as this adds new VoLTE profiles compared to the stock firmware that came on the modem. This helped to the point where I could place calls and they would connect and the other side could hear me, but I could not hear them. I have not worked out that last hitch yet.

Is there a firmware upgrade for the Librem 5 modem that might help with this similar to the pinephone situation above. I have read some posts about the different firmwares that can be upgraded on the Librem 5 but they seem to be lacking in information about the modem firmware, for example here. Maybe my search engine game is weak but I have been unable to find much about upgraded firmware for the Librem5.

It would be greatly appreciated if someone could point me in the right direction for getting calls to work over VoLTE on my Librem5 whether this be via upgrading the modem firmware or another means.
Any reports from people able to use their Librem5 in Australia on VoLTE would also interesting.

Thank you.

1 Like

Contact Purism Support (support@puri.sm) for instructions on upgrading your modem firmware.

@irvinewade

3 Likes

This was my experience getting 4G calling to work: Librem5 Update | adamd’s place

2 Likes

Yes, I am using my Librem 5 on the Vodafone network in Australia, and using VoLTE, and it works.

(I didn’t change the modem firmware and my phone is quite old as I was an early backer.)

You will need to have installed the package bm818-tools and it will need to report successfully what the current firmware version is. Have you done that?

If it achieves that then you would need to enable VoLTE with that tool and then you need to reboot. And then it should just work.

1 Like

Thanks @irvinewade, it is good to know L5 is working with Vodafone on 4G.
I think I have made some progress after your input.

  1. I had read about using bm828-tool so I ended up cloning it from git and running the scripts directly. I couldn’t fine it in the pureOS store (Gui) nor via apt in the terminal, I think a typo got me there. I was running the scripts directly. bm818-volte on indicated that it had done what instructed but it made no difference. bm818-fw-check was just returning an empty string and bm818-volte-check was returning BMRAT status not active always.

  2. I was able to install bm818-tool via apt-install and launch the gui that I had seen images of online. It shows VoLTE as enabled but calls are still not working. Firmware is
    M100E_YCSN0_1.0.0_210830
    YCSN0_M100E_1CMD_B227_V1.0.0.1_20210907
    M100E_1.0.4_200715
    Screenshot below

  3. I am not sure what CBS enable is but it does not seem to affect the calling situation and it will not stay enabled across a reboot, not sure if that is relevant.

Thank you all for your input so far. I have also emailed customer support but have yet to hear back from them.

`

2 Likes

Rebooted after enabling VoLTE and before attempting a call?

Yes, ignore. Nothing to do with this. CBS is the Cell Broadcast Services. Not sure that’s even working yet.

1 Like

Strangely, the apt package name is bm818-tools, while the name shown in the app grid is “BM818 tool.”

And you’re right; it doesn’t seem to be in the store (at least under either of those labels). It’s only available via apt.

1 Like

Yes, I rebooted after enabling. And I tried disabling (with reboot) and re-enabling (with reboot) but it makes no difference.

I do see often an orange exclamation point over the cell reception signal bars. It comes and goes with time. Setting the access point name in the settings makes it go away. Making a call sometimes makes it come back, but not always, and calls do not work regardless of if it is present or not.

1 Like

I believe that this is telling you whether mobile data is enabled. I think it might be a known bug that data sometimes goes away. It may not be relevant to whether VoLTE calls work though.

Then your next step is probably to stop in with Purism Support to get them to pass judgement on whether your modem firmware version is appropriate. Your versions are very different from mine, albeit that yours appear to be newer than mine, and that it is difficult to interpret that alphanumeric soup.

2 Likes

This is the date on your modem firmware^

Mine is 20220930

2 Likes

Thank you everyone for the help. I was able to get in contact with purism support and they sent me a link to new modem firmware which has resolved the issue.

For reference for anyone facing a similar issue:
My Librem5 was ordered Dec 2018 and delivered Nov 2022
The original modem firmware it came with was dated 20210907 and did not work for VoLTE calls on Vodafone network in Australia
I got a link to a newer version which is dated 20220930 and does work for VoLTE calls.
The full firmware version is
M100E_YCSN0_1.0.0_220926
YCSN0_M100E_1CMD_B227_V1.0.0.2_20220930
M100E_1.0.4_200715

5 Likes