Librem 5, Cellular Network Testing

Nah, I kept my modem. I make due with wifi calling via while at home. It is just annoying to not have reliable cell service at home. Please do update anything you find out from them. I will do the same.

That’s a separate application. Think Network Manager.


I think it’s network manager gui

I deleted that package some time ago. Do yiu know the exact name? Was it in Librem 5 goodies perhaps?

The package name is network-manager, it is installed by default on PureOS, shown when “List All Apps” is toggled.

1 Like

I apogize but I deleted it and I am having trouble finding it in Apt. I am missing the GUI.

1 Like

Probably network-manager-gnome. My /etc/apt/sources.list is:

deb byzantium main
deb byzantium-updates main
deb byzantium-security main

If you do edit this file, execute sudo apt update, then try installing the missing packages.

Any of these look promising to you?

network-manager-fortisslvpn-gnome/byzantium 1.2.8-2+b2 arm64
network management framework (Fortinet SSLVPN plugin GNOME GUI)

network-manager-l2tp-gnome/byzantium 1.2.18-1+b2 arm64
network management framework (L2TP plugin GNOME GUI)

network-manager-openconnect-gnome/byzantium 1.2.6-1 arm64
network management framework (OpenConnect plugin GNOME GUI)

network-manager-openvpn-gnome/byzantium 1.8.14-1~pureos1 arm64
network management framework (OpenVPN plugin GNOME GUI)

network-manager-pptp-gnome/byzantium 1.2.8-3+b2 arm64
network management framework (PPTP plugin GNOME GUI)

network-manager-ssh-gnome/byzantium 1.2.11-1 arm64
network management framework (SSH plugin GNOME GUI)

network-manager-vpnc-gnome/byzantium 1.2.6-3 arm64
network management framework (VPNC plugin GNOME GUI)

1 Like

None of those; after executing sudo apt search network-manager, I get this:

network-manager/byzantium,now 1.30.6-1+deb11u1pureos1 arm64 [installed,automatic]
  network management framework (daemon and userspace tools)

network-manager-gnome/byzantium,now 1.20.0-3 arm64 [installed,automatic]
  network management framework (GNOME frontend)
1 Like

I appreciated the help; however, Apt tells me that I already have those packages installed. The problem? No GUI. Don’t know where I put it . . .

1 Like

You access it with the “Show All Apps” button in the app drawer.

The app name is “Advanced Network Manager”.

Sorry, it is not there.

However, this command was helpful:


See here: networking - How do I run GUI version of NetworkManager on DWM? - Ask Ubuntu

1 Like

Hello. No, it does not.


I didn’t realize I missed so much. It’s been a hectic few days. Sorry


The holiday season is upon us, so I will not be surprised if activity in the Purism community forums will become noticeably slower until next year.


sudo apt install nm-connection-editor

This app is useful, on the L5 just as on any Linux computer. It allows you, as the name suggests, to create any kind of advanced connection, such as shared ethernet, VPN, etc.

The VPN connection settings UI allows you to set up VPN service even when your VPN provider doesn’t have a graphical client that runs on the L5. (Unless you prefer to do all that in the terminal.)


By the way, you can use these commands to determine what’s installed and what a desktop package’s name is:

dpkg --get-selections
(This lists all installed apt packages.)

ls /usr/share/applications
(This lists only the desktop applications.)

ls /home/purism/.local/share/applications
(This lists any user-created applications.)

flatpak list
(This lists all installed flatpaks.)


Does that include ip over USB that network manager won’t fsck around with after it is setup and connected?

1 Like

As a follow-up to this thread. I wanted to let everyone know that I did finally get the home cellular amplifier to work.

The problem: oscillation between the antenna and the in-home amplifier unit. I had the in-home unit too close to the antenna. I also had the in-house antenna too close to the booster.

I bought another antenna and booster with a little better amplification. I am sure the amplification with larger coax cables helps, but the bigger issue is the new unit reports back oscillation problem. The Yagi antennas are pretty much the same unit - as far as I can tell.

Anyway, I have cellular in a large portion of my home now. The Librem 5 is not having difficulty picking up the signal, in most instances. I have 2-3 bars of 4G service, where previously I had none. The

mmcli -m any

command and the “resetmodem” shortcut from another thread are most helpful for testing cellular signal on the Librem 5.

The BM818 modem was not the problem. I was the problem. Makes the most sense when you think about it. Now, the BM818 modem is not my favorite modem, but I will say that it has worked much, much better for me since I update the firmware last fall.

Anyway, that is the report back and I hope that anybody who had cell reception problems at home is not afraid to try an amplifier at home. They do work as long as the user installs them correctly and watches out for distances between antenna and amplifiers - both outside and inside the home.