Librem 5 Dev Device not detecting Wifi

After following the instructions at , my device is unable to access any wifi.

running nmcli device wifi rescan results in:
Error: No Wi-Fi device found

dmesg | grep -i sdio shows “RSI-SDIO WLAN: probe of mmc1:fffd:1 failed with error -110”

The physical switch is in the “On” position.

does anyone have advice on how I can get wifi to work?

I don’t have a clear answer for you, though I can ask the developers for hints. If I was troubleshooting this myself, I would start at the nmcli man page and see what other information I could get out of it. Maybe the nmcli radio command is useful.

Hope this helps, anyway. :slightly_smiling_face:

Yes, actually it was helpful. After powering up the device to read the man page, I went through the steps again, and wifi was worked as expected; so something I did on the machine prior to going through the network setup had screwed things up. :confused:

1 Like

It’s good to know that it works now.
Sometimes it seems that turning it off and on again really is good advice. :wink:

1 Like