Librem 5 Dogwood vs. PinePhone PMOS CE

OK, so I’ve been playing around with my PinePhone in the little spare time I’ve had in the last week. I got my personal taste of Phosh, and I like it – still can’t wait for my Evergreen (the email I got today teasing me about shipping has me all hot and bothered).

I grabbed a cheap Tracfone T-Mobile SIM from Wally World and soon had a 4G connection, with about 17 Mbps down. So now, in no particular order…

  • Phone calls take a long time to connect, and there is no ring indicator, but they work (seems to be 4G only). Audio quality is not great – it usually sounds like I’m in a wind tunnel to the guy on the other end, sometimes choppy.

  • The volume control buttons do not work and there is no onscreen volume control.

  • The headphone jack does not produce audio. I checked the DIP switch, and it is set to audio, not UART.

  • Bluetooth connects to my car stereo (I think), but I’m not sure how to test it. I guess I’ll stream some web audio and see if it goes through. Maybe this weekend. If anyone has a recommendation for a Bluetooth keyboard, I’m all ears.

  • Battery life is pretty limited. I get around 4 hours with the cellular radio on and the screen off. It will definitely not last the night. I’ll have to try it in airplane mode, but if I do that overnight, I might as well just turn it off. That won’t really be an issue when I get some USB-C cables strategically located around the house and in my vehicles.

  • SMS works.

  • Contacts work, but are really bare bones.

  • No email client.

  • No audio or text chat clients.

  • The onscreen keyboards are OK, but vary from app to app and you can’t always dismiss it.

  • The software store says there are 3 repositories, but searches turn up nada. I tried going to the command line, but then I discovered that PMOS is derived from Alpine (super stripped-down Arch), so no “apt get” for me. I tried “apk” – it’s there, but now I gotta go learn it and I haven’t had the time to mess with it, yet.

  • The browser is desktop Firefox with the user agent spoofed to report Android. Most pages work OK on the screen and load fast. Sometimes FF will freeze the phone. I have SSH setup, but haven’t tried using it to try to unfreeze the phone (by killing FF) yet. Can’t really get to the settings dialog (must be off-screen). Need to try about:config.

  • There is no file explorer GUI, but I’ve browsed around the file system using the “save” dialog on the text editor and the command line.

  • I’ve tried several known good SD cards, but they don’t mount. I haven’t tried manually mounting them from the command line, yet. I need to search out the syntax for that in Alpine.

  • I have not yet tried the dock/converter. Users on the Pine forum seem to have had good results.

Where does the PinePhone shine?

  • Price

  • Feels like a quality build in the hand. Stuff is aligned nicely, the screen is easy to read and the back cover comes off easily.

  • Pogo pins (no time to play with them yet, but they’re there).

  • It took 2 to 3 weeks for my order to process, then 3 days to ship DHL to California.

  • The Pine64 Store has hard and TPU cases for $10 each and tempered glass screen protectors for $5. I didn’t order them until after the phone arrived, but the order has already been processed. Probably be here early next week.

I don’t have an L5, so I can’t make a direct comparison, but based on what I’ve read in the forum and the Purism updates, I’d have to say that PureOS is much more complete and polished than PostMarketOS. To be fair, they are aimed at different user communities, and while the installed software seems to update frequently, PureOS appears to be way ahead in OS and software. I definitely like the PureOS convergence model better than the stripped down PMOS model, which I assume is that way for performance reasons.

I don’t mind scripting some things, but at this stage in my life, I appreciate a rich GUI, and PMOS ain’t it. I’m not going to wipe it off the phone yet, but I am going to put Mobian-Phosh on an SD card and try that, mainly so I’m in the more familiar Debian-based environment. After that, maybe Debian-Phosh?

I have to say, playing with the Pinephone is sort of like being a teen and playing around with the girls to get experience and check things out. Truth is, I have my eye on the real hottie (Librem 5). She could turn out to be a dud, but I doubt it. She’s gonna be a keeper!

I really, really appreciate all the hard work Purism is putting into the OS and associated software. :heart_eyes:

12 Likes

Honestly your observations don’t surprise me. A true Linux phone was always going to require a monster work load. That Purism has tried to tackle that with their limited staff is impressive no matter how you look at it.

Really looking forward to the Librem 5 as well.

But I have to be honest that I’m REALLY looking forward to Librem 5 v2! I would like double or triple the amount of RAM, and a much more powerful CPU.

9 Likes

i cant stress the line enough: L5 BATCH FIR 4 WIN

PMOS is very rough. Honestly I’m surprised they thought it was in a good enough state to ship, but I guess it’s a development version and all.

Still, most of these aren’t issues on Mobian (and I assume PureOS, although I haven’t been able to get it to boot on my Pinephone).

  • Phone calls have some kind of ring indicator. It doesn’t sound like a ring, more of a buzz, but it’s something. Call quality is vastly better than on PMOS.

  • Volume buttons work. No graphical feedback though unless you already have a volume indicator pulled up.

  • Headphone jack works

  • Battery life is much better, I’d estimate around 8-12 hours. I think Mobian implements CRUST, which helps with battery life but means the phone occasionally takes a while to turn back on when you wake it

  • Uses apt, seems to have many more packages available than PMOS

  • Comes with GNOME Web and Firefox. GNOME Web is more optimized for the phone interface than Firefox, but Firefox generally performs better than GNOME Web.

I think the only thing preventing PureOS from working (following the steps from [Successful] installation of PureOS on PinePhone) is a patch to u-boot needed for the RAM to be recognized properly. I don’t have time to test it now unfortunately, but it would be interesting to see how it and Mobian compare, both being Debian-based.

3 Likes

postmarketOS’s goal is to support a lot of older phones, so they removed a lot of stuff that requires extra storage and extra RAM. Mobian has the luxury of assuming that the phone has 16GB of storage and 2GB of RAM, which allows for a more complete system closer to standard desktop Linux. Because Mobian seems to be focused exclusively on the PinePhone at this point, it seems to me that they have done a better job of fixing the PinePhone bugs and customizing Mobian to work well on the PinePhone’s hardware.

I love the idea of being able to extend the life of old phones with postmarketOS, but I’m not sure that it is a viable model, because way too much is locked up with blobs and we can’t access documentation for the components, so I’m not sure that postmarketOS will ever work well, beyond a few models such as the PinePhone which were designed to work well with FOSS.

3 Likes

Speaking about Yesterday’s teaser email, in the U.S. for what modem should I ask?

They just started builds for the Pinetab also.

BM818-A1 is the best option in the US. If you are really paranoid about Chinese manufacturers, you might consider the PLS8-US, but it doesn’t support many bands and it will cost extra, because Purism has to pay for custom manufacturing of its M.2 card, whereas BroadMobi offers M.2 cards as a standard option (according to its web site).

1 Like

Not paranoid, more like a cranky old man saying “Get off my lawn!” at the kids on the block.

1 Like

UPDATE: The PinePhone PMOS CE Wi-Fi hotspot works… technically. I can setup the hotspot and my laptop connects to it. I can ping out to the world, but the throughput is a measly several kbps :face_vomiting: – even when I get speeds over 15 mbps on the phone itself.

Gotta try Mobian!

2 Likes

What file system is on the SD card? ext4? FAT?

It is possible that support for any file system that is not needed for the main disk is not included. So assuming that the main disk is ext4, I would try formatting the SD card to ext4 on another computer - assuming that there is nothing of importance on the SD card.

I would expect that the mount syntax would be standard

mount device mount_point_dir

where “device” is the path to the SD card reader device e.g. /dev/mmcblk0p1 and “mount_point_dir” is an empty directory e.g. if you are in your home directory, mkdir sdcard and then use sdcard

I noticed that too. I have some SD cards that work fine on my laptop. But when I plug them into my old Dell R720 they ain’t there.

I personally think the SD slot on my Dell was disabled or is maybe just a faux slot. (Although the spring that lets me push it in and out again works.)

I originally formatted them on a PC, probably XP, for use on my Galaxy S III. My guess is FAT32 or exFAT. I hope I’ll have time to find my USB adapter this week, then I’ll check to be sure.

1 Like

OK, maybe I was hasty about the SD card and pmOS CE. I tried the old SD cards on my Linux Mint workstation (HP Z230) and my Linux Mint ancient HP laptop and they beep, but the don’t mount. The disks utility sees “USB Mass Storage Device” with a device (sdb or sdc, depending on which machine) and a serial number, but size and media are blank. I believe these cards are good and have data stored on them, probably FAT32, since the computer I last used them on was XP.

I tried new 128GB cards in both Mint computers and get the same treatment.

Both of these computers mount USB thumb drives and external USB hard drives. I expect they are OK and so is the PinePhone pmOS CE. What am I missing?

Out of curiosity, have you tried popping them into your pc and then opening gparted or something similar and seeing what it has to say about the SD cards?

I had a thought, the newer SD cards come with a USB kit. Instead of plugging into the SD slot, I should try mounting one in a USB housing and see if that works.

Yes. GPARTED showed nothing and none of my PCs have an SD slot. I always use a USB-microSD adapter or a USB-SD adapter with a SD-microSD adapter. I can’t find the last one right now, so all this info in this thread refers to the USB-microSD adapter with 64GB and 128GB microSD cards. My stinking Galaxy S III (which is almost dead) reads them fine.

Unfortunately, sometimes the SD-USB adapters that come with the SD card are of extremely low quality and do not ensure the normal operation of the SD card with the computer. In such cases, the OS may not see the memory card or reading information from the card may occur with numerous errors. I know this from my own experience.

1 Like

… they just go bad. I can confirm this too.

Funny, I could not remember the word “adapter” at that moment. That’s why I used “kit” and “housing”. I suppose you’re right, it may not be the best solution, but if it worked …?