Librem 5 Evergreen Help

Was working fine through today. Put it to charge while off, tried to turn it on afterwards and the LED light went green, but nothing shows up on the screen. No changes in colour or anything else. Solid green light. Pls help.

Maybe take a look at this documentation :

Thank you but all I get from that is “The U-Boot bootloader has started running”.

Maybe try to disconnect the battery, wait few seconds, then put it back
Maybe test if the phone is booting when plugged with charger and no battery


it happened to me and i did what aipei suggested and it worked. it hasn’t happened since. some kind of one of glitch hopefully

No luck, unfortunately.

I guess @dcz or @dos may have better ideas

A flashing green light is a symptom of the bootloader starting followed by a reset as a result of insufficient power.

Did you followed those particular steps (yes, just partially, several times or something else), as @fralb5 already recommended? Please, which one doesn’t work for you (or provided work around solutions for Librem 5 are still in development phase)?

1 Like

I once thought my Librem5 would not start, but with low battery it changed the brightness automatically so far, that I did not notice, that it had started.


@aipei, how about leaving looking at green LED light aside, as I would like to know if you already separated Librem 5 battery from the phone for at least few minutes, turned all Hardware-Kill-Switches off and continued from fourth step, as described (and linked) here: Librem 5 not charging.

If red light constantly on, as it should be, perhaps leaving Librem 5 charging for some time (one hour or so, not sure how long) before pressing power button (turning phone on again).