Librem 5 not charging

Remove the battery, insert it back, and try again…?

Try this procedure if you have Evergreen. Instructions for earlier editions are also on that page.


tried that - didn’t make a difference

I do have Evergreen.
Now it is more like Everblack.
Didn’t work.

1 Like

Two pieces of advice based on my experience with a Librem 5 Birch:

  • The orientation of the USB-C cable can matter. Even though it seems symmetric it is really not. For me, it will only charge if I have turned it the “right” way so I put some tape on the cable to see which way should be up.
  • If the battery got completely drained it needs to charge a really long time, like several hours before it shows any sign of life.

So I would recommend letting it charge for a few hours, then turn the cable around and let it charge the other way for a few more hours so that you are sure you have given it the chance to charge in both ways, then after that try to start it. Removing the battery and putting it back can work if the power button does not seem to do anything.

1 Like

See here please:


Nope, doesn’t work.
Any other ideas?
As I said - I hardly used it during January
I updated OS yesterday.
That’s it.

Check the USB cable…? Use another one…
Check the battery voltage using a voltmeter…

Does the phone works without the battery at all, just by providing power via the USB cable?

1 Like

It doesn’t

I read elsewhere(don’t remember where now) that you must use the charger and the cable provided.

Honestly … but I don’t have a voltmeter

Okay, do you have any details, for example, do you get red indicator at all at step 5?

1 Like

Thank you for replying.
No red dot at all.
Yesterday during the time the device was working i got all colours yellow green violet/purple red

Is it resetting of bq25895 charge controller for over 11 seconds, through power button, of any help?

After some brief testing we did, we found that pressing the button for roughly 11 seconds caused the charge controller to reset.


Thank you, @Quarnero
@mladen I am afraid the answer is still no red light or any light of any sort.

1 Like

Hey guys, to cut the story short: if the reset instructions are not working, then we need to accept possibility that the hardware is faulty. The best is that you contact so that we see what to do next.


Thanks all.
Purism support here I come.

1 Like

It seems that maybe you broked some parts into the L5.usb-c port, this happens if unplug, plug the cable wrong.

How do you plug in a USB type C cable wrong?


You must be joking.


Using too much force? Too much angle? It’s not like they are indestructible.


On many times forcing by angles in plug ang unplug, it loose or broke the port.