Librem 5 is not reading SIM card anymore

Suddenly Librem 5 is not reading the SIM card, I tried to remove and insert the SIM again even replacing the SIM with a new one no luck. Is it a modem issue or there’s something I can do to fix the issue?

When removing the s.i.m or putting back the SIM Card to Librem 5 it need complete OFF the device otherwise the SIM may malfuntion.

The sim is working on other mobile devices :frowning:

It all HKS turned ON?

Yes, sure. The modem is working but not reading a sim.

I don’t know it is the same issue, but 1-2 months ago my Librem 5 (when I was using it as my daily driver) just stopped working with the modem (or maybe just the SIM?). Once I got home I did a few troubleshooting steps, including reseating the modem and making sure that the antenna wires were correctly attached to the modem card. I think my final step of troubleshooting that fixed it was going to the modem settings in Gnome “Settings” and switching on the slider to enable the modem connection.

Yes, I’m using it daily and it was sitting on the table, suddenly is not reading the sim. I toggled the slide off and on but no luck :frowning:

Check the button for on-off modem on posh

Already did… didn’t help

Is this from an error message in a log file or something else?

Do you have a SIM PIN? If so, are you being prompted for the PIN?

Obviously the SIM card needs to be in the correct slot and in the correct orientation. Are you using a uSD card in addition to the SIM card?

It’s time to try a sim card from another phone that is functioning. Don’t ask how I know. I got to the same point as you. My sim worked in another device and as far as I could tell the L5 was functioning. Yet with my sim in the L5 it showed no registered cellular provider when for months that had been no issue. Even with the switch from 3G to 4Glte.

Next I put in a family members sim from a whole different service provider and network. It came up immediately. Mother-you-know-what. My L5 was purposely shut down. Probably by 1 of 3 sources or a combination. And yet at least for the cellular backbone it was operating on, we know that our L5s are allowed in certain instances. So I really have no way of knowing the source of who was responsible for cutting my device off.

After all the other things we deal with and with all the above in mind; I am PISSED.

Anyway, that’s the next thing to try. Your L5 may be functioning just fine.

1 Like

I tried another functioning sim, also not working :frowning: :frowning:

It was working perfectly but suddenly it’s showing no sim inserted.

Your last two posts just made me think of a few things. After I tried and checked all kinds of things with the L5 like scouring these forums and tutorials - nothing worked(for me). Next it was time to call my service provider and make sure my account showed it was active and functioning and the sim card didn’t get zapped somehow. Everything tested out with my sim card in a different open device. So on their end with the final salute to me, paraphrasing “And since your IMEI device isn’t supported you can get something that is or take a hike.” Not quite like that but effectively that was the message.

The kicker is if a sim card to test was used from or on a locked device it didn’t work. And the first family members I grabbed was a newer phone with a recent plan that discounted the phone blah blah. So the sim was locked to that newer device. Then I brainstormed and knew there was an older phone around that was active and luckily a nano sim. Then it came up no problem.

Seperately, while the phone was down between trouble-shooting, I had also loaded the git BM818 4Glte script that supposedly worked some things even a bit beyond enabling the 4Glte part of the modem. I don’t know if that had anything to do with it but it sure didn’t hurt.

Other than that, it’s all I have as of now.

  • Strange behaviour, what about removing the batt for 2 minutes with HKS ON.?
  • Before declare a hardware issue reinstall GNU System into L5.

Thank you for your answer! I can confirm the steps fixed the issue.

1 Like