Librem 5 MMS Australia

I have tried to activate MMS on the Telechoice network in Aus.
I have configured Mobile and Chats for MMS and it almost works.
Settings Mobile Mobile Data on APN Name TeleChoice-MMS APN mms
Chatty MMSC APN mms Proxy
I send an MMS to the Librem 5 and , sometimes days later, I get a SMS saying my MMS had expired.
I would like to ask anyone in Australia with a Librem 5 if they have MMS working.

Or in general has anyone got MMS working on Librem 5?

I got it working on my Librem 5 with ALDI mobile connection ( they are also using Telstra network services).

My working MMS settings ( purism@librem5:~/.mms/modemmanager/mms )

[Modem Manager]


Helpful information for your provider:

1 Like

Ok that worked. Much appreciated

Under Settings Mobile Access Point Names I needed to set u[

Access Points

Nam Telstrs(next G)
APN telstra.internet

1 Like

The MMS is interpreted as a plain text document . I have SMIL turned on.
I feel I am missing some software that can process the MMS properly as I
get an option to use anotherr app to open the file.
The data is getting opened by Thunderbird Mail, that I previously installed.
Perhaps I need to uninstaill Thundebird, It is not working properly anyhow

An update.
MMS is working well can send and receive photos.
Thunderbird is not causing any issues. I uninstalled and reinstalled TB.

The MMS coming through as text is a Vcard,
Thunderbird saw the MMS Vcard as an email and I opened the attachment as text
PRODID:-//Apple Inc.//iPhone OS 16.5.1//EN
FN:Cxxxxx Kxxxxxxx

I am happy MMS works , and I dont really need VCARD support, but I am curious
is there a better implementation of VCARD support.

fwiw I saw this post from João in 2021. Is it something relevant to MMS Vcard?
I am unsure if I should install syncevolution`

joao.azevedoSupport technician

Oct '21

unzip the file in your librem 5 phone. You might need the package unzip for that.

cd into the subdirectory: output and just do: sudo apt install ./*.deb to automagically install all the syncevolution debs

ps. I use Thunderbird only when L5 is docked and I have a large display. TB does not work well on small phone display.

hi, at this moment the contact apps already supports importing contacts directly from a vcard.

1 Like

Hi frank,

Can I ask a small favour? I had big issues with the Telstra network (with Exetel) and MMS. It was working for a while, and then one day it stopped and never worked again. I swapped to Optus, but that’s not ideal either.

If you don’t mind, and are OK with the terminal, would you be able to run the following?
journalctl -b -0 | grep cdc-wdm0 | grep modem-broadband

You don’t have to include the details, just whether or not you can get an IPv4 static configuration, and an IPv6 one.

(All that command does is search for log messages including “cdc-wdm0” and “modem-broadband”. I suspect my issue is that I stopped getting IPv4 configuration).

No worries if you prefer not to do this.


I see this info hth

Jul 19 02:00:20 pureos NetworkManager[469]: [1689696020.6228] modem-broadband[cdc-wdm0]: IPv4 static configuration:

Jul 19 02:00:20 pureos NetworkManager[469]: [1689696020.6339] modem-broadband[cdc-wdm0]: IPv6 base configuration:

1 Like

@frank or @nscomputing, I’m on Optus, do you happen to know how to set MMS for Optus?

Using the GUI when I go to Access Points I see:

Westnet (iPhone)

That one has a blue dot in it

Under that is

Westnet (all except iPhone)

Truthfully no I have not set up Librem 5 MMS with an OPTUS sim.
But I can try to help. It is tricky without enough info.

Have you turned Settings/Mobile Data On ?

please list the contects of your file**~/.mms/modemmanager/mms**
I will see what setting OPTUS recommends and try to suggest.
I dont promise any results to be achieved.

Do you use a dock? It can be finicky to work on the small phone display, are you able to set up a dock and use the std keyboard mouse and monitor, I use ’ bonelk 7 port dock , it has USB C port for power, connect the librem power supply to it) Connect mon keyb mouse and cat 5 iEth cable to your network)
Then in Settings/Displays you can select to use the large monitor.
I use Thunderbird on th Librem 5 , you cannot find and easy installation instruction for TB on the net.
I used sudo apt-get install thunderbird That was simple enough/ But TB only works well if you have a dock and use a large monitor.

Thanks @frank, I appreciate tou.

I thought I did, but apparently not. So I’ve toggled it on, it goes to the Access Points which comes up with

Westnet (iPhone)

Under that is

Westnet (all except iPhone)

When I click the settings wheel it comes up with:

Name: Westnet (iPhone)
APN yesinternet

Name: Westnet (all except iPhone)
APN internet

Where do I find my username and password?

How do Ido this because when I type file**~/.mms/modemmanager/mms** into the terminal I get:

No such file or directory.

When I cd into ~/.mms/modemmanager and ls there are three .status files and mms file.

When I try to cd into ~/.mms/modemmanager/mms file it says it’s not a directory

No, I don’t have a dock

I think usually left empty for most mobile network providers.

I think the intention was that you type the command at the shell prompt
cat ~/.mms/modemmanager/mms
and whatever output you get, post it here.

Thanks @irvinewade

I think usually left empty for most mobile network providers.

I think the intention was that you type the command at the shell prompt
cat ~/.mms/modemmanager/mms
and whatever output you get, post it here

Okay cool. Thanks for that.

So, @frank, based on the above, the output of cat ~/.mms/modemmanager/mms is:

[Modem Manager]


You can see Optus APN settings for Android here:

Optus MMS Settings for Android:

Name: Optus MMS
APN: mms
Proxy: Not set
Port: Not set
Username: Not set
Password: Not set
Server: Not set
MMS proxy:
MMS port: 8070
MCC: 505
MNC: 02
Authentication type: PAP
APN type: mms
APN protocol: Ipv4
Enable/disable APN: APN Enabled
Bearer: Unspecified
MVNO type : None
MVNO Value : Notset


Thanks frank, that pretty much confirmed something happened either on the Telstra side or an L5 update that stopped me getting an IPv4 address. I guess the MMS/mobile stack doesn’t support IPv6 only.

Hi Nico1,

I’m on Optus now due to the Telstra issues I mentioned above. (Actually,, which uses the Optus network).

Some of these are from memory, as I had to put the sim back into an old Android, too many issues with the L5 for now.

Step 1: choose the “yesinternet” APN, disable WiFi, and confirm you can access the internet, like through a web browser.

Step 2: manually create a new APN, called “Optus MMS” or similar. Enter as many details as possible from nscomputing’s post above, but note most don’t get entered when adding a new APN. From memory, the APN is actually the only one needed.

Step 3: open chatty, the SMS/MMS app, open Preferences from the 3-line menu, open “SMS and MMS Settings”, then enter:

Step 4: now here’s the catch, you can only have mobile internet or MMS messages at once, due to a (hopefully temporary!!!) restriction on the L5. To get MMS messages, go back to the APN screen and select the APN you created in Step 2. Then you should be able to send MMSs, and receive any sent to you.

So how to do you know when you have received an MMS? Run the following command, and if anything appears beyond the “mms” file, you have a message to download:
ls .mms/modemmanager/

I was writing a script that would automatically notify you, but that is on hold until I go back to using the L5 with the sim.

Let me know if you have any questions.


Hi Nico
I think everything stookie says is good, he knows more than me.
NSComputing is the guy who sorted got my MMS config.
Just want to add
Under Settings / Mobile / Access Point Names ,
I suggest in your case these settings
Create a new Access point named
Optus MMS

Name Optus MMS
APN mms

I believe the APN named in here in Settings needs to be the same as the APN you set up in Chats or is it chatty? preferences. (preferences is accessed by tapping the icon of 3 bars when you open Chats)

1 Like

Hi Nico1

When you get an opportunity to do the OPTUS MMS config, I am curious to know if it worked for you.


Thanks for all the info and help @frank , @stookie , and @nscomputing.

I’ll be looking into it all over the weekend or early next week.

Will let you all know how I go.

1 Like