Librem 5 not always sending tone for automatedmenu


i’ve noticed that the librem 5 (at least in the past 2 weeks) does not always send tones when pressing number keys which the automated menu on the other end receives.
also when redialing it still occurs. I have not tried rebooting yet (although i reboot regurally because of updates or when the modem just doesn’t want to play nice)

does anybody know if this is a bug or a setting?
i’ve only noticed it since about 2 weeks, before that i did not have this issue

i’ve never heard it make a tone, but it usually gets send/recognized on the other end.

this is kind of a critical thing if you want to use the librem as a cellphone. I love the librem but i still don’t trust it to work ^^
i really hope it can be made/improved to work continuously so i can trust that it is always there when i need the cell service. It’s still a bit to buggy on the cell side

also followup question:

can i manually force reset the modem? i think i read about the watch-modem script and similar things, are those on the librem by default i can i call them to restore the modem other then to reboot or wait for the script?

just tried the reboot that seems to fix it. still weird that i’m calling and can hear the other side but i can’t tone dial. Maybe the outgoing audio stream died or something?

I do not have that issue with my voicemail. I just checked it yesterday and had to delete more spam voicemails from telemarketers using the dialpad.

I did encounter issues with DTMF in the past. See this issue. But it has been a long time since I encountered this issue.

Toggle the HKS

I get that bug every now and then. Then again I don’t make a lot of regular phone calls.

1 Like