Librem 5 shipping email

Thanks for trying to help. :+1:
Not sure what went wrong. I installed qemu on a Windows tablet and on a Ubuntu laptop. On both machines the Librem 5 emulation did not progress beyond the start up swirl.
It might be a resources problem, it might be a matter of tweaking some start up parameters. Next time around, I will have a look at a that bios setting. i might get things working in the end.
But at the moment I am mostly just annoyed that I wasted a couple of hours waiting in vain for the bloody thing to get going.

indeed that is what it is at the present moment.

i managed to snag a 512GB Shangsung-Pro NVME (970-pro) back in late-2018 for ~200 $(less if i remember correctly but it was not USD currency so i might mess up the number but not by much)

F*ck! It’s like we never left the nineties…

Why does this:
sudo qemu-system-x86_64 -boot menu=on -drive file=librem5r4.img format=img -vga virtio -display gtk -m 2G -enable-kvm

result in this:
WARNING: Image format was not specified for ‘librem5r4.img’ and probing guessed raw.
Automatically detecting the format is dangerous for raw images, write operations on block 0 will be restricted.
Specify the ‘raw’ format explicitly to remove the restrictions.
qemu-system-x86_64: format=img: drive with bus=0, unit=0 (index=0) exists

If I am not mistaken the format is specified as ‘img’.

So, if you leave out the format specification it runs. That figures…
Let’s see if it results in a working emulation…
(Enabled the VT-x option in the BIOS, btw.

But of course, after that, bugger all happens…
This nice for developers, but you can’t blame regular customers that they do not check out the emulation: it is unworkable.


If I were you, l would read this topic.
Last time I tried I used Gnome-Boxes and it worked like a charm :+1:

The .img file is for the Librem 5.
If you are trying to run this on a x86 Linux PC, then you need to be using a qcow2 file. For example:

sudo qemu-system-x86_64 -boot menu=on -drive file=qemu-x86_64.qcow2,format=qcow2 -vga virtio -display gtk -m 2G -enable-kvm

Wish that sort of info would be documented somewhere.
(And why is the image file named the same as the qemu command?)

1 Like

To let you know that that one is the one you should use in qemu I guess.


Somewhere that is easier to find (for a non-developer), then, maybe.

And it still seems strange to name an image file the same as the file you use to load said image file.

Anyway. Thanks again. I hope this will finally work.

the developer mind works in mysterious ways …

1 Like

It works!
Thanks a bundle, amosbatto.
In the end it took just three command lines (an apt-get for qemu, the image download, and the qemu execution), and a bios tweak to get things going. Not that hard. Wish the documentation would have been that helpful. (It could, for instance, be a lot easier to find a link to the right image file.)

The wait for the Librem5 is getting so frustratingly long, that I decided to have a look at an emulator. Would be nice if it was a tad more accessible.


here ! you might find it helpful if you’re messing with QEMU >

Thanks, reC. I will check it out.

Yes, the image build page is confusing and there is no stable link to get the latest Qemu image, so you have to hunt for it.

That be a Negative. Today is the 50% mark for the month of Nov. Looking forward to an email soon.

1 Like

@davedarr, Several people have reported getting the email, but it only went to people who were offered Birch, Chestnut or Dogwood, and they declined in favor of Evergreen. To be in that group, you probably had to order the Librem 5 between 2017-08-24 and 2017-08-30.


Thanks for the info. I’m in that group but I haven’t received the email yet.

Im assuming your referring to this…?

1 Like

Nope, not this one, seems you ordered mid-oct 2017 (categorized as ‘general backer’), so you will be after the USA version

1 Like