Librem 5 touchscreen issue on boot

I have not used my L5 for a while. When I just tried to turn it on again, the prompt for to unencrypt my drive came up, but the onscreen keyboard does not work. It does not seem like touch events are being registered. On top of this if I try to plug a keyboard in via the USB C it does not work either.

So currently I can’t use my L5. Has this happened to any of you? Were you able to resolve it?

1 Like

I’ve had touch screen issues intermittently, but not right at boot. While the phone was already turned on and encryption code entered. I would swipe up on the arrow to unlock, and the touch pad would be totally unresponsive to enter code. Simply turning the screen off/on always resolved it.

1 Like

I guess it MAY fixed on next incoming Gnu Core update. I already using this version of core, which all working good. However this bug show up randoms, so to bypassing this bug reboot the device until get worked.

GnuCore(Opensourced: LinuxKernel)

1 Like

No, never, but I have had issues with entering the PIN on Byzantium as @TacticalPandaLE described.

Crimson on the Librem 5 utilizes the plain variant, so I do not use LUKS at the moment, for better or worse.

Just speculating based on limited information but I don’t think this is a touchscreen issue. Seems more likely that something is failing in the early boot.

You might try Jumpdrive in order to take a peek at /boot to see whether anything is obviously wrong although I wouldn’t know what specifically to look for.

Did you :mag: because I have a feeling that other people have experienced something similar?


Yeah I figured as much. Honestly, I just don’t have the time to tinker with it. Not sure I understand why any change was pushed and accepted that would cause this instability for the end user.

There is still a LOT of room left before this is ready for the prime time.

1 Like