Librem 5 USA internet connectivity issue

Hello I have been having an issue with my librem5 suddenly it wont connect to the internet through wifi webpages simply wont load if i go to the pure store there has been an update there for almost a month if i try to download it i get thjs error and hopefully someone here can tell me how to resolve it "
error: unable to download updates:E:Index of /pureos/ byzantium-security/main arm64 libuv1 arm64 1.40.0-2+deb11u1 is not yet available (could not resolve ‘’)

1 Like

Any chance you’ve been mucking around with a VPN?

Anyway, basic network troubleshooting, open a terminal and ping a host on your local network. In other words, forget about the internet and just see whether you are successfully on your local network.

As a separate, independent line of exploration, are you implying that it will connect to the internet via the mobile network? Do you have a SIM in the phone?

For the purposes of testing, it may make sense to do the test using the Kill Switches so that in the second paragraph, WiFi is on and Mobile is off - and in the third paragraph, WiFi is off and Mobile is on.


Use the Terminal instead:

sudo apt update && sudo apt upgrade

Ensure your date and time on the device are correct first.

thank you for your reply yes i have had a vpn installed since I purchased the phone back in 2021 been fine, I have uninstalled the vpn thinking that may be the issue unfortunately that didn’t resolve the issue I am using wifi because my memory card fell off the sim tray and i cant remove it it’s seems to be stuck down the bottom of the sim slot this happened years ago and hasn’t/doesn’t cause any issues i am trying to send the phone back to purism for repair, so no no sim in the phone.

1 Like

thank you I have tried that command it spits up a simmilar error, I have tried ping and it seems to work.

1 Like

There is some discussion in this forum that uninstalling the VPN causes the problem that the DNS server gets left messed up. So you can access the internet by IP address but not using any domain names. I suggest you search for that discussion.

Then next try ping

(That’s a Cloudflare server with a memorable IP address - and it will respond if your internet is working.)

1 Like

thanks i tried that and it works fine so i don’t know what to do other than maybe a complete wipe, only thing is i have never been able to get the librem to connect to a pc to backup connecting usb i have tried windows and linux it makes the littlr pop noise when the phone is connected but the librem doesnt show up anywhere I did try going to settings and the share tab and selected to share but that didn’t do anything

1 Like

You can use Jumpdrive to backup your eMMC on your Librem 5:

Then hunt down the discussion that I alluded to (about how installing and then deinstalling a VPN breaks the DNS configuration).

But, yeah, reflash will do the job. It’s just overkill.

Well for sure if you want help in this forum, you will need to be using Linux.

Even if you fumble the fingers to get the phone into Serial Download mode, it should still show up e.g. via the lsusb command. Do it before plugging in the phone. Do it after plugging in the phone. See if anything extra showed up.

1 Like

Yes Fedora, Pop OS or Android. :wink:

1 Like