Librem 5 won't boot

Your L15 has PureOS already?

It does, but I don’t know that it would help. I’ve tried connecting my L5 to my L15, but I don’t see the connection anywhere even after taking steps to install uuu.


You should get this output:

When you see above output present, as it should be there, please prepare your next steps based on posts #48 and #74 (as mainly related ones), those you can find within this very same thread.

1 Like

That blog post points to the original location of the librem5-flash-image tool. It has been moved


The phone doesn’t need to boot to put it into serial download mode. The way to guarantee the phone gets to serial download mode.

  1. unplug phone and remove battery
  2. hold vol+ and re-insert battery
  3. while still holding vol+ plug in the USB cable connected to the laptop

run dmesg on the laptop and it should show that an NXP device has been connected.

You can always connect for help with the reflashing procedure


I am having the exact same issue and I own 2 batteries for Librem 5. It won’t boot, so I guess I am going to have to flash an image tog et it to work again? Its a pain in the @$$

1 Like

Not necessarily. It depends on what exactly the problem is.

You might want to put the phone in serial download mode but boot Jumpdrive so that you can view the contents of the phone’s partitions from a host computer.

When I attempt to turn on my Librem 5 I get a green indicator light, but the phone doesn’t actually boot, i.e., nothing shows up on the screen.

This happened to me after OS updates were performed via the PureOS store “Updates” tab. Subsequently I was not able to boot. Instead just got a blank screen and a green light as OP described. My solution, very unfortunately, was to reinstall PureOS.

1 Like

I am trying to reinstall PureOS and the balena etcher is not recognizing any connected device when I plug my phone into the PC. Then I successfully flashed PureOS to a SD card, phone just won’t boot even after the holding up, plug in, then insert battery. Nothing can be easy! lol Any suggestions anyone?

As far as I am aware, at the current time the Librem 5 is not directly capable of booting from uSD card. So that is a non-starter.

What is the operating system on the host computer? (Etcher appears to be available on all of Windows, macOS and Linux.)

When plugging a Librem 5 into a USB port on a Linux computer the behaviour observed on the Linux computer will be different depending on whether the Librem 5 is in serial download mode or not. I suspect that if the Librem 5 is not in serial download mode and is borked then it may be that nothing will show up on the Linux computer e.g. with lsusb

When in serial download mode, lsusb gives the clear indication:

Bus 999 Device 999: ID 1fc9:012b NXP Semiconductors i.MX 8M Dual/8M QuadLite/8M Quad Serial Downloader

(where the 999 values will be different for you).

If you aren’t seeing Serial Downloader then something is not right, regardless of what should happen after that (e.g. reflash using the reflash script or boot Jumpdrive).

1 Like

running Ubuntu (Zorrin), ran dmesg, got some red lines in a bunch of lines saying device not accepting address 9, error -71

also a few other red lines, just not sure what commands will help in this situation or if there is anything I can do to fix this device.


I’m using actual Ubuntu (22.04, kernel 5.15.0) and connecting via USB to the Librem 5 works, both with the Librem 5 in serial download mode and with the Librem 5 booted normally.

What kind of USB port are you trying? I’m using a regular USB 3.0 port with a USB-C to USB-A adapter and/or with a USB-C to USB-A cable (because my computer does not have any USB-C ports).

With the hypothetically reversible USB-C connector, it is always worthwhile trying the 4 possible orientations. (Using a USB-C to USB-A cable at least cuts that back to 2 possible orientations.)

This kind of problem would be just one reason that I recommend that people try out serial download mode before they need it. :wink:

I have tried both the USB-C cable that came with the phone and a regular USB as my PC has ports for both. Is there like a step by step link somewhere on this site that can walk me through commands to try to get this device to work again? I got this phone two years ago off ebay so I didn’t buy the device direct from Purism, but ordered an additional phone from Purism like almost everyone else, I am still waiting on.

1 Like

Have you followed the 7 step physical procedure from here?

Bear in mind that where it says “the script will continue” does not apply if you are not actually running the script and for the problem that you appear to be having, I wouldn’t be running any script (yet).

Do you have a recent enough kernel? e.g. corresponding to what Ubuntu version?

The bottom line is that until lsusb shows the phone appearing as a USB device, you will not be able to reflash or boot Jumpdrive.


Yes, very important step to rely upon, thanks! lsusb and in particular below command, actually its output needs to be satisfied before actually reflashing any Librem 5:

1 Like

I chose not to go that far because until we know what version of “Ubuntu” is involved here, we don’t even know whether uuu exists. (It only appeared in the standard Ubuntu distro in recent versions and who knows whether it is in Zorin.)

1 Like

yeah, I mean Zorin is sort of like Mint or other variations of Ubuntu, but I am unable to locate uuu when I put in the command to install it. I mean is there only a fix if one is using vanilla Ubuntu? Is there even a way to say get uuu through maybe a WIndows command line? Just seems a little strange Purism help instructions assume you are running very specific versions of Linux to troubleshoot the device?

uuu is the Freescale/NXP I.MX Chip image deploy tool and can be found on github there are even prebuild releases and yes it even works on Windows but I don’t think the script that Purism uses the uuu tool would work on Windows without some modifications.

1 Like

Well, not really. When I started with my Librem 5, Ubuntu did not include uuu and I had to build uuu from source, which I did successfully. So I would give you some hope that anything in the Debian family is worthwhile to try.

The real challenge if you are going to use some other member of the Debian family is knowing what it might be roughly equivalent to in terms of version baseline.

You could also try taking a recent Ubuntu Live Boot and boot that.

This also works if you are using PureOS, or at least I would assume so.

Linux is about choice and freedom - but that also means the freedom to run a distro that noone else here does. :wink: