Librem 5 Won't flash and Won't boot

When I got my phone a few weeks ago it would boot. It wouldn’t hold a charge for more that a few hours but it functioned. I tried at least a dozen times to get it into flash mode. Remove back, remove battery, plug cable into computer and phone usb while holding volume up button down and while still holding button down insert battery. The led lights worked like they were suppose to but NEVER saw any script except in normal boot. Tried it with multiple cables and while still hooked to charger. Now it won’t even boot any more. The leds work for what that’s worth. And I did run lsusb on the computer, the phone never did show up.

1 Like

What operating system are u using to perform?

SystemD OS?
Torvalds OS?
Linus OS?
Opensource OS?
Darwin OS?
Cow OS?
Dog OS?
Gnome OS?
Chocolate OS?
Bruno OS ?
Ghost OS?



OPenSuse 15.4 and Tumbleweed

@DanielRS, please follow this procedure:, as first enable every HKS (disable modem card, etc.).

After around two hours of charging (constant red LED light on):


You cannot reflash your phone with empty battery, yet this is irrelevant at this point.


The battery was not the issue. Was charged. Holding the power button for 18+ seconds did get it to boot. Now, how do I get it to go into flash mode? Did the 18 seconds reset some software in the phone?

1 Like

No, it just disconnected the battery from the rest of the system for a short moment, making it fully reset.

Entering flash mode is an simple as holding Vol+ button while the phone is being turned on. There will be no visible indication of entering it at all (no LED, no vibration etc.) - the CPU will just silently wake up and stay on. At this point, the phone should be visible in lsusb when you connect it to a PC via USB.

Since no visible feedback can make it somewhat confusing when things go wrong, here’s a more complex procedure meant to mitigate any possible edge cases that could go in the way:

The phone should also show up in lsusb (although with a different entry) when it’s fully booted up. If it doesn’t show up no matter what, there may be some hardware issue.