Librem does not start fully - what to do?

All of a sudden, my Librem 5 does not start the phone graphical shell any more after booting.

When I start the phone, I’m prompted for the disk encryption password. The password is accepted, but next the screen keeps empty (black) and the backlight is on.

I tried to ssh into the phone, but it is not accessible.

Any suggestions to debug this issue?

I tried rebooting and removing and putting back the battery, but that did not solve the issue.

1 Like

I would use Jumpdrive to mount the phone’s filesystems and browse the logs:

mkdir ~/jumpdrive
curl -sL | tar Jxv -C ~/jumpdrive

# nxpmicro-mfgtools
# set all killswitches, remove battery, hold volume-up, plug in librem5, place battery, release volume-up
sudo uuu ~/jumpdrive/purism-librem5.lst

To determine how the phone’s emmc and sdxc storage is attached use dmesg or ls -l /dev/disk/by-label/ and mount accordingly.


Possibly related: Screen doesn't come on after power-on - #19 by guido.gunther


Many thanks @ookhoi.

I followed your instructions. Unlocked the LUKS partition, and ran fsck on the encrypted file system. There were indeed problems with the file system. fsck fixed them, and my Librem 5 continues the boot into the graphical phone shell again.

So great to be in control of your device, and having a community that provides help!