Librem Mini 2 No HDMI Signal


I just received a new Librem Mini yesterday and I had planned to use it (at least temporarily) headless. To set it up, I had planned to connect it to my TV via HDMI. When I booted it, I could see the bootloader screen and the boot selection options, but beyond that, the TV reported no signal. I’m curious if there’s something I need to do on first boot (boot from USB to install PureOS?) or if there is something about a TV’s settings that might need to be changed to get this to work. Unfortunately, I don’t have another compatible monitor I can try.


is this connected to a 4K TV/display by chance?

PureOS should be preinstalled on the device/drive, so you shouldn’t need to boot from a USB unless you’re trying to install a different OS

It is! Should it not be?

it should work, I’ve just heard of one or two others having the same issue. They were using a 4K monitor and solved it by switching to the DisplayPort output. I’m guessing your TV doesn’t have a DP input, so perhaps try a DP->HDMI 2.0 adapter and see if that works any better?

I had the same issue with my Mini v1, with a 2.5k monitor

given it’s the exact same board, not surprising. The issue is related to the LSPCON (level-shifter + protocol converter) used to provide HDMI 2.0 output, since Intel’s GPU doesn’t support it natively

I have the same issue with 4K monitor on Mini v2, I can only get as far as to GRUB, but then input dies.

Is using DP really the only fix? According to store page, Librem Mini has only DP 1.2 so it’s far older standard than HDMI 2.0

how is “older” problematic given it supports 4Kp60? Just because HDMI was late to standardize on modern resolutions?

1 Like

I’m not much intro hardware, so I was just concerned there may be lesser quality, latency etc. But I was surprised a device uses a 10-year-old standard, why is that? Intel GPU limitations?

you mean HDMI 1.4? LOL.

DP 1.2 is more than enough capability, unless you’re trying to run multiple 4K displays from a single port, or 4K > 60Hz. The standard being 10 years old just shows how forward thinking it was at the time.

1 Like

Is this not something that Purism would be supporting in the kernel? Is that even possible?

Also I’m the same medicineman25 from the reddit group and this appears to be my exact issue :sweat_smile:

What do you mean by this? Support what exactly?

Apologies, still getting used to this forum.

I’m referring to the LSPCON used in the device. Is support for that module coming in the future? Just seems a little odd that it was used and paired with a CPU manuf that won’t support it… I’m obviously not understanding a lot of how that works.

it’s not unsupported, it works for ~95% of users without an issue. It’s not something that the OS/kernel driver is aware of typically.

Sorry, I’m using the wrong words again. Yes, 95% of users.

Oh ok cool so not kernel. Interesting.

I’m thinking about this from the pov of like a typical device e.g. Lenovo etc, where arguably 99-100% (??) of HDMI use cases in this case screens are supported?

Not a criticism or a complaint, genuinely interested in how this works and what has happened with this scenario and how it differs from the average consumer device.

if we’re talking just about consumer laptop/desktop devices, then it depends:

  • AMD GPU/APUs do offer native HDMI 2.0 output
  • Intel CPU/GPU/SoCs 10th gen (Cometlake) and earlier do not support native HDMI 2.0 output, and if boards using these offer HDMI 2.0, must use a LSPCON of some kind
  • Intel CPU/GPU/SoCs Icelake and newer support HDMI 2.0 output natively via the GPU

With the Mini v1/v2, we are using a Parade LSPCON (which is a pretty standard part), but still dependent on the VBIOS (blob) to init the GPU with the standard coreboot/SeaBIOS firmware. We’re still working on getting coreboot native display init working fully with the LSPCON. Pureboot users should have no issue since the i915 driver handles the display init

Oh ok cool, I didn’t know that about Intel chips. Thanks for taking the time :slight_smile:

Over a year later Ive been able to try this and it works! Ive installed Kodi and been controlling it via the remote app, but would also like the option of controlling it with my TV remote via HDMI-CEC (I think), which is how I used to control Kodi when i ran it on LibreElec on my Raspberry Pi. Any idea if this is possible on the mini?

the Librem Mini does not support HDMI-CEC unfortunately

1 Like

Great to know - thanks! Is there any kind of remote I can get to replace this kind of behaviour? I’ve been controlling Kodi with the iOS app or web control interface, but that’s a bit inconvenient if my phone or laptop isn’t nearby. I’m guess it would have to use Bluetooth?