Librem One Email Error


#1

I am getting an error when sending email through Librem One. It says the server doesn’t allow relaying if my mail…blah blah blah.

Has anyone else had this issue?

Thanks


#2

Could you show the actual SMTP session log or actual SMTP error? (with censoring if necessary)

Generally this (my guess of) error comes down to one of two possibilities:

  1. The server is misconfigured i.e. you are specifying a domain that the server should be accepting but isn’t.

  2. You are doing something that they are not allowing i.e. you are specifying a domain that the server should not be accepting.

In some cases the behaviour for either (1) or (2) will depend on whether your outgoing SMTP session is correctly authenticated - so you might want to verify that if it is relevant.


#3

Not sure of the issue. It is the same settings as before and it worked. I will try deleting the email account and reinstalling.


#4

I deleted and reinstalled my account on my i"Trackyou"Phone. It still said the server does not allow relaying.

Here are my current settings.
Incoming Server
limap.librem.one
Server: 993

Outgoing
smtp.librem.one
SSL (yes)
Server: 587

It worked until a few days ago. Now, nothing. I can receive. I cannot send any email. I am all ears to anyone who has an idea as to why.

Thanks.


#5

The exact language says, "A copy has been placed in your Outbox. the recipient XXXXX@XXXXXX.com was rejected by the server because it does not allow relaying.

I am definitely willing to relook my settings. I thought someone had an email setup guide. If someone has that or their settings, I would be very grateful. I am not certain what changes happened that made this happen.

Thanks.


#6

Well…muddled through it. Got it too work. Copied my basic settings from my Librem15. Voila!..it worked. If anyone else has any issues, I am definitely willing to share.

Thanks.


#7

A company that is not your ISP and which provides to you an outgoing mail service will typically relay email for all destination domains but you must authenticate i.e. provide a username and password to the outgoing mail server that are correct for that server. My best guess is that somehow that username and password got cleared or messed up. (Following a setup guide or copying settings from somewhere else might correct such an issue.)

Note that the username and password need not be the same as for receiving incoming email although if the two services are provided by the same company, it is more sane to have authentication in common between the services.


#8

I will have to agree. I went back and looked at my outgoing settings and for the most part they were cleared out.

I cannot wait until our Liibrem5 phones are ready and shipped to us.


#9

Just for future reference:

librem.one/#faq contains the following:

What details do I need to set up Librem Mail in the iOS Mail app?
Follow the steps from Apple to Set up your email account manually with the following details:
Account type: IMAP
Host name: imap.librem.one
Outgoing mail server: smtp.librem.one
Why is configuring Librem Mail in the iOS Mail app so hard?
Librem Mail is a new email provider. Our server details are not yet recorded by Apple and unlike other clients, the Mail app doesn’t perform this lookup automatically.

With a link to https://support.apple.com/en-us/HT201320#manual

I know you solved your issue, but for what it’s worth, you wrote

limap should have been imap - not sure if this was just a typo in your post, or was actually the problem in your real configuration.

But glad you got it sorted either way!


#10

I appreciate the assistance. Yeah…it was a typo…lol. I went ahead and copied my setting from my Librem15 and it worked.

Not sure what happened. I looks like all the settings somehow got erased/removed.

None the less, my email account is back on my iPhone.

Thanks.