Librem Qubes Users, Some Qs For You


#1

A) Has Qubes been stable for you?
If so, what version are you running?

B) Are you using Ethernet, thru a USB?
If so, how did you setup the Ethernet adapter to work with sys-net?

C) Are you getting random Lightbox failed to start errors when trying to start VMs?
If so, did you find a solution?

D) Were you able to get OSX to work inside a VM?
If so, can you point me to a guide that shows me how to do it?

Let me know the answers to any or all those Qs.

P.S. I would really, really love Qubes to work, and be stable enough for a primary OS. It might be I’m just a newbie to the Linux scene… but so far, I just haven’t been able to make it work without random, unsolvable errors. If you have been able to please let me know, that at least it is possible on Librem hardware with current 4.0.3 Qubes version (or an older one if necessary).


#2

A) Yes, since 4.0. Running it fully updated to the current version with no problems on a Librem13v2.

B) Have been using Ethernet on a combined usb/net qube which I had set up during install. Adapters on USB-A as well as USB-C ports worked quite well. Sometimes the device disconnects for no apparent reason and immediately reconnects. Sometimes it vanishes and I found I can solve the issue by turning the USB-C adapter by 180 degrees. Don’t ask me why that is, I was never bothered enough to find out.

C) No.

D) Never tried.


#3

A. Yes, running 4.0.3 (but have been running it on Librem hardware since the 3.x series)

B. Yes, I have to use the widget in the top panel on the right-side that allows you to attach USB devices to VMs, to attach my USB Ethernet adapter to sys-net whenever I plug it in

C. No I’ve never seen that error before. If you are running on Librem hardware, I’d make sure you are running our latest version of firmware (https://puri.sm/coreboot has steps to download and run our installer, which on Qubes you will have to perform from a PureOS USB Live disk instead, due to the outdated flashrom on the Qubes dom0).

D. Never tried.


#4

To clarify:
Dom0 qubes updates are outdated? Is that the core reason (seems that the problem developed after running Qubes update).

If Dom0 has an outdated flashrom, and that has been the core problem, how do I update Dom0 without messing up the flashrom? How are you updating it?


#5

Dom0 is based on an older Fedora than the Fedora or Debian versions used for other Qube templates. I update my firmware on my Qubes systems by booting off of a PureOS USB live install disk and downloading and flashing the firmware using the steps on https://puri.sm/coreboot .


#6

A) I’m using 4.0.3
B) No
C) I do get this error on occasion, and a reboot solves the issue. It seems to happen after updates sometimes. I’m past due for a Pureboot update, though.
D) No


#7

@Kyle_Rankin: Questions regarding your answer for B): After attaching the USB Ethernet adapter to sys-net, are there any additional steps taken? Or were there any VM setting that had to be modified for this to work?

I ask because when using a USB-C to Ethernet adapter on my Librem15v4 (with Pureboot beta 11 firmware + Qubes 4.0.3), after attaching the device to sys-net, an “Ethernet Network” item appears in the network widget drop down menu with no available networks. I’m not able to ping any IP from sys-net after this. Could this be a driver issue?


#8

I didn’t have to do anything extra, it saw it as an Ethernet adapter and the NetworkManager daemon in sys-net picked it up and attempted to get a DHCP lease.


#9

Thanks for your answers. They give me faith I can get Qubes functional.