Librem SIMple service

Looks like Purism finally has a more reasonable option for users who don’t want unlimited*(?) mobile data.


Finally. I assume its still T-Mobile?

I also imagine there’s some tracking involved since data usage has to be tracked.

For the AweSIM service it looks like Purism switched to only have AT&T as a backbone, so my assumption is that the SIMple service is using the same AT&T backbone.

That’s a nice option, and one which will generate more business, I’m sure.

1 Like

I might even give it a shot, as my attempts to get VoLTE working directly on AT&T and on T-Mobile haven’t gotten VoLTE calling working.


Alright! Let’s order that Librem phone and …

$1200 phone (not USA model) delivery one year out. Librem USA only four months to deliver at $700 premium. Wish I was rich enough to own a Tesla and a Librem phone.

1 Like

Tesla might take you where you don’t want to go. :wink:


… and even if it doesn’t, it is probably reporting to someone where you do want to go.


I’m giving Purism one last chance. I just ordered a new modem (because I’m concerned I put my original modem on a blacklist for AT&T) and the SIMple service plan. If Purism can make cellular service work on my Librem 5 without extensive hassle, I will happily use it as my daily driver for my business. If they cannot make it work, I will be selling my Librem 5 and getting an Android phone and flashing it with probably CalyxOS or GrapheneOS.

Oh my goodness. The new modem and the Purism SIM with SIMple service came in today. I replaced my old modem (which I feared I had put on a blacklist for AT&T’s network), installed the Purism SIM, booted it up, and it seems like things are just working without having to configure anything. I mean, this is the way it should be, but I had little hope that Purism could make it happen. I was wrong, however, as calls when on 4G-only seem to work and texts seem to work. I’m honestly a bit shocked and maybe just a bit giddy.


It turns out that MMS is not working yet. I’m in contact with Purism support to see what settings need to be configured to get MMS working.

CORRECTION: it looks like MMS is working when I enable “Mobile Data” and “Data Roaming” in the mobile settings.