Librem Tunnel on Kubuntu

As of installing, after the liberty command it Tilix comes back with this:

Traceback (most recent call last):
File “./.local/bin/liberty”, line 6, in
from scripts.liberty import cli
File “/home/szeshu/.local/pipx/venvs/ldh-client/lib/python3.7/site-packages/scripts/”, line 2, in
from scripts.nm_tunnel_setup import nm_tunnel_setup
File “/home/szeshu/.local/pipx/venvs/ldh-client/lib/python3.7/site-packages/scripts/”, line 17, in
gi.require_version(‘NM’, ‘1.0’)
File “/home/szeshu/.local/pipx/venvs/ldh-client/lib/python3.7/site-packages/gi/”, line 129, in require_version
raise ValueError(‘Namespace %s not available’ % namespace)
ValueError: Namespace NM not available

What should I do?

Hmm, so, there’s a Python script looking for a particular version of NM (and since the Python script is setting up the VPN tunnel, this NM likely stands for “Network Manager”), but the gi package that is requiring NM is associated with Python access to the GTK library.

Given that you are using Kubuntu (and the KDE desktop environment), which is primarily Qt-based, rather than GTK-based, I think you are missing something that GNOME would otherwise provide.

Not sure what the best solution is here. We can ping @jeremiah and @joao.azevedo and see what they say.



When installing librem tunnel in Kubuntu, how did you tried to install it?

Did you followed the steps in this howto:

Was there any error message during the installation?

What command did you ran when you got that error message?

1 Like

Yes I followed those steps and all responded az expected, than the final step of command the: ./.local/bin/liberty tunnel-setup
When it happaned and I got stuck


Can you please install the following dependencies:

  • python-gobject
  • python-requests

from a terminal just do:

sudo apt install python-gobject python-requests

Then reboot the machine and try again the command:

./.local/bin/liberty tunnel-setup

Let us know if this solved your problem.

Installed them, gives me the same exact result as I originally posted.

Maybe they are missing from the virtual environment? In which case, I don’t think sudo apt install would fix the problem

Tried with Pop_OS (Middle of distro hopping, not sure if that’s a right approach :-/ ) now it returns with this:

File “./.local/bin/liberty”, line 10, in
File “/home/rodnas/.local/pipx/venvs/ldh-client/lib/python3.7/site-packages/click/”, line 764, in call
return self.main(*args, **kwargs)
File “/home/rodnas/.local/pipx/venvs/ldh-client/lib/python3.7/site-packages/click/”, line 717, in main
rv = self.invoke(ctx)
File “/home/rodnas/.local/pipx/venvs/ldh-client/lib/python3.7/site-packages/click/”, line 1137, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/home/rodnas/.local/pipx/venvs/ldh-client/lib/python3.7/site-packages/click/”, line 956, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/home/rodnas/.local/pipx/venvs/ldh-client/lib/python3.7/site-packages/click/”, line 555, in invoke
return callback(*args, **kwargs)
File “/home/rodnas/.local/pipx/venvs/ldh-client/lib/python3.7/site-packages/scripts/”, line 19, in tunnel_setup
File “/home/rodnas/.local/pipx/venvs/ldh-client/lib/python3.7/site-packages/scripts/”, line 70, in nm_tunnel_setup
gi.repository.GLib.Error: nm-vpn-plugin-error-quark: cannot load plugin “/usr/lib/x86_64-linux-gnu/NetworkManager/”: /usr/lib/x86_64-linux-gnu/NetworkManager/ cannot open shared object file: No such file or directory (0)

@Rodnas sorry for taking this long to get back to you.

If you are still having this issue with Kubuntu, i was able to reproduce your issue in a VM running Kubuntu 19.04

I was able to solve the issue in my installation (Kubuntu 19.04) by:

1 - Installing: gir1.2-nm-1.0

2 - following the install instructions in

As for the error in Pop_OS, it another issue.

@Rodnas To solve this issue in Pop_OS you most likely need to install: network-manager-openvpn