Librem13 doesn't work with USB-C docks?

This adapter works with Google Pixelbook and with Lenovo X1 Carbon providing dual video and USB.

When I plug it into my Librem13 nothing happens. It doesn’t even show up in lsusb, or dmesg.

Does librem13 not support USB-C docks? If it works with some, which ones?

Is there another dock I can use on the USB 3 A port that anyone can recommend? (though it’d be a real shame to not be able to use the same dock for Pixelbook and librem13.

The reason is most likely (can not confirm since I do not such a device) that this dock is a Thunderbolt device. The USB-C connector on the Librem laptops does not support Thunderbolt, sorry.


I see. I read the name of the adapter as USB-C (which, fair enough, is only a connector as I understand it), and also supports thunderbolt. But what you’re saying explains it.

Do you happen to know a similar dock that provides video as well, that is compatible with the librem laptops? It’s fine (actually better) if it uses USB-A, presumably the USB 3.0 port.

I am currently using this dock:

Caveats: You need to make sure your xorg-server server is not newer than version 1.19. I’m not running PureOS, so I don’t know what version it has. Also, you need to figure out how to install the proprietary DisplayLink driver which was designed for Ubuntu. This might help you on PureOS, as it is Debian based: You need to start/enable the driver service through systemctl, and then you can interact with the displays as you normally would.

I’m looking for any recent experience using an usb-c usb 3.0 dock to connect a Librem13 v4 running PureOS green (like delivered by Purism) to external devices.

I’m looking for an usb hub to connect mouse and keyboard, an ethernet card (could be connected to the hub also, but would be nice if built into the dock) and if possible a video output for an external monitor.

Anybody out there using something like that and willing to share her/his experience?

I’m using the HDMI-port and a USB Hub for this. Unfortunately a compatible dock (without fiddling around) doesn’t seem to exist.

Same here :slight_smile: - I’m using an usb-c network card with an additional usb port and on that usb port an usb-hub to connect mouse and keyboard.

I wouldn’t mind fiddling around a bit like mentioned by @swinny if I’d new that I’m not alone and that somebody already succeeded and is happy with the solution (and its maintenance).

The “HP 3005PR USB 3.0 Port Replicator - USB Docking” swinny pointed to worked out of the box for me with Debian and librem13.


You are going to want to steer clear of USB-C docks for additional displays on Purism products. The USB-C spec has lots of optional features which Purism has not implemented, including the additional displays feature. USB 3 docks are what you want, like the one I linked to above.

Thanks a lot for all the information!

I’ve now got connected to a Librem13v4 an i-tec USB 3.0 Docking Station that works fine so far (didn’t use audio).

It didn’t work out of the box and it uses closed source drivers provided by DisplayLink only for Ubuntu.

@swinny mentioned the very helpful script to install the drivers into Debian which does not work on PureOS.

The script checks whether it runs on a support distribution by reading lsb_release -is and lsb_release -cs. On my system the result is

user@system:~$ lsb_release -is
user@system:~$ lsb_release -cs

To use the script one needs to substitute the lines for checking for Debian with the values from the output of lsb_release - like e.g. for my computer

# Debian
elif [ "$lsb" == "PureOS" ];
        if [ $codename == "amber" ];

But even after that change for me the script didn’t fully work.

I ended up reading it and the installation scripts contained inside the driver package by DisplayLink and check step by step was had been missing.

In the end it worked, but it’s not been anything someone without knowledge of udev, systemd, shell-scripts should try.

But yes, the hardware I bought works and I can now dock by just connecting one USB-connector and my power connector.

Edit: I didn’t work with wayland. Had to switch back to Xorg.

Update here: Still the usb dock I wrote about works fine with the manually installed displaylink drivers. But I ran into the issue that the second screen would not show a picture or even be visible in after reboots or starting up.

For my situation I found a solution I describe here.

There are also a lot of issues talking about Debian Buster open (at the moment of writing this) so maybe the script provided in the repo will work now or in the future for PureOS based on Debian Buster, too.

1 Like

I have a Nllano usb-c/3 ethernet adapter that includes 3 usb ports. It works out of the box.

I’ve got two of similar ones, also.

The difference is that these do not provide a connection for another monitor.

in PureOS ?

in PureOS ?


1 Like

Any idea if a cheap USB-C dock bar like the following will work on Librem laptops and the 5? Does some Purism-page exist with advise on purchasing USB-C docking stations/bars? Thanks.

Does HDMI work out of the box, and what resolution do you get?

The Philips 328P6VUBREB monitor contains a docking station over USB-C. The description [1] does not mention Thunderbolt. Does that mean that it will work with my Librem 13?


Depends what parts of it you want to work, and which specific Librem hardware. If you are only interested in video-out over USB-C then my guess is:

Librem 13 and 15 … no
Librem 14 and 5 … yes

If you are interested in power-in over USB-C then I would guess the same again.

1 Like

I am particularly interested in HDMI-connection in the docking station. I read somewhere, that the interface to the DS must be USB3, not Thunderbolt. Does that mean that I can use any USB3-based DS, e.g. this one, which seems to suit my needs: