Librem13v2: New battery wont charge”

Yes, I am the same person who was writing about breaking WiFi chip cable connector that goes back to antenna. On a Librem 13 V 2

I decided to see if the thing would just function, with a new battery from Amazon.

so I taped the end of the Antenna connector back. Put it back together.

I tried to start it in Qubes, as that was where the Boot was pointed at. I have this set on the Pure boot mode which does not require the Librem Key. Pure boot showed the battery had 101 percent health of battery, and zero percent charge. Lights start at WiFi green, power green , the middle light is slow flashing orange. I have charger plugged in.

Gives the same options as used to be, I enter the disc password, takes a really long time. Then starts recovery mode. Well, the last time I started Qubes it did not close properly. Might be right. I power off and start again. I have Purism on the other drive, so I try to change to it to start Pure OS. I change the boot options Then screen goes blank, I have the slow blinking orange light.

The 14 documentation says to set a 14 to trickle charge by pressing the increase volume for 5 seconds, and plug power back in.

Blinking orange light is gone. After twenty minutes, I try to start again, and now no lights come on, nothing on screen.

Yesterday the fellow in the computer store seemed to think the power charger produced voltage.

I notice on the left side there is a place for a paper clip, that says “reset” ??? I don’t know what this reset is for.

I really wanted to use computer, not experience, all kinds of ways for it to not be useful.

I think I saw a post somewhere of a fellow who wanted a battery that was fully charged. I understand the feeling.

After the Librem 13 V2 did nothing. I held the start button down for 10 seconds to cycle into being off. Unplugged, and plugged back in the power adapter.

Pressing power button yields nothing. No Lights, nothing on screen. not even the blinking orange light.

I will leave it plugged in for an hour or so. I am not trusting enough to leave it plugged in while I am gone.

If no one can suggest an option here. Maybe Monday I will open it and unplug main battery for a few hours. Perhaps replace the CMOS battery.

The fellow at computer store does not have any specialized knowledge of PureBoot, so paying him will not help. He can only read forums about problems.

Thanks for any assistance.

Please make a good statements overall. Example in header. “Librem13v2: New battery wont charge” instead “New Battery wont charge” and so on…

So the Librem13 v2 is working well when is plugged to DC power even if the battery does not get charging??

Thank you for suggestion on post header. You are correct, your choice is more clear.

When I first received computer, it worked fine. Some days ago, I was at library, started update in Qubes. Got message, running out of power (or like that) Plug computer in. I thought it was fully charged. After the screen went blank the first time, I could only get some ‘Pure Boot’ messages. Then nothing.

As of now, The computer does not work at all, under any option I attempt. I do not have a Power Bank. I only have mains, which are AC through the Power Adapter.

I was just thinking that buying some kind of Power Bank, probably less expensive than Librems (less quality). Does the Librem 13 V2 accept charging from Power Bank? I guess through USB? How big of a one do I actually need to, at worst, get Pure Boot Re-Installed.

See what happens.

What do you suggest?

The power adapter converts the AC to DC, just FYI, so you and @carlosgonz are talking about the same thing.

But just so we’re all on the same page, you’re saying the laptop won’t come on either using the battery or using the power cord?

Yes, you are correct, As of right now, the laptop does not respond at all. No lights. Blank Screen. I tried both modes.

Guessing it is a logic thing. Not enough battery power such that the charger will charge it.

Earlier this morning it would start Pure Boot, Then went as far as to allow me to enter the password for Qubes. After a long time it went to Recovery Console. Which I have never used. I tried to start again, and change it to boot the other partition, which has a working partition of Pure.

I went to stage where it, three times, flashed the startup change. then screen went blank.

Hypothesis is that the computer either does not know how much the battery is charged. Or the battery was nearly expended when I got it.

In truth, it is doing the same thing now it did with battery that was in it, when I received it.

What you think?

2 things happening… or the Charger is Dead or the Motherboard is Dead.

  1. Try testing the L13-charger on other device also testing the L13-motherboard with other AC-DC charger.
  2. Open the librem 13 case for a fisical inspection.

I did not see anything wrong when I had the back off this morning. Nothing black, nothing smells like burnt. And I am not sure if that means anything.

I have no other way to test things. The fellow at the computer store used his voltmeter to determine that the power Adapter was giving the correct voltage.

I have seen other laptops, where, if the battery was really low in charge. Then the laptop circuitry would not allow the charger to charge the battery. and in fact, the computer would not run off the Power Adapter either. If one replaced the main battery, it computer would function normally again. I don’t know if Librem is like that. ???

I have seen where someone said their Librem would not both charge, and run while the charger was charging. Of course, the laptop could still charge while it was turned off.

I read, The directives that set the limits on when it should charge, for Qubes, are in a file that should be written and placed in dom 0. I had hoped to get back to the partition which had Pure OS on it. then let it charge, or at least, I hoped, whatever Pure does for directive be set. Then I could turn it off and it could charge.

Might be the computer had started to try to install the Pure Boot upgrade, then ran out of power, even though I plugged in the power adapter.

Guessing you know more about this stuff than I do. I am certain, that if the main battery is low enough in charge, it will not run, it will not allow the charger to charge it, and the charger can not run the computer at all. I am guessing these settings are meant to prevent fires. I had to buy batteries for computers which had this problem. they had standard Windows type BIOS

The EC microcontroller is manager of the battery status, so when you pluggin the ac-dc charger the Librem 13 has to be turn ON the light notification for charging, even if the L13 does not have battery inside or battery damage inside or even without pureboot or ssd.

Why post this in the “Round Table” category, rather than in the “Librem” category? Please see the category descriptions:

Round Table
Welcome to the Round Table! This forum category is intended for certain types of topics that are either non-technical, highly subjective, or otherwise don’t fit well within other existing categories. This might also include general discussions about operations, philosophy, business, etc.


Questions, thoughts, ideas, and other stuff regarding the Librem hardware are welcome here. NOT MEANT FOR CUSTOMER SUPPORT!

(Although the Librem category is not meant for official support, you can certainly ask for other members’ help and guidance there.)

Also, be aware that Round Table is the only category here that is not visible to the general public. One has to be signed in to even see it. So, you will get more eyes on your questions in the other fora.

P.S. You can change the category if you edit the title, assuming the edit symbol is present for you.

I thought it either hiccuped, or a moderator moved it.

1 Like

Listening to the information from Carlos. I performed an experiment. I unplugged that main battery. Plugged in the Power Adapter. No lights.

The guy at the computer shop (he is very good at repairing computers, so he has experienced a lot) When he first looked at wire and WiFi, he said he could just solder it on. When I explained that it was not just a wire, but a cable, a bit like Coaxial Cable with center wires insulation, sheath of something else conductible. And also explained what little I know of taking off the display top to replace antenna. Which is to use a blowing warm air to loosen glue. He suggested I throw a four year old laptop computer away.

That this laptop is a bit unique in some ways. As my income is a meager sum from Social Security, I can’t afford what I might think I want.

I am scheming to save it.

I am guessing I should buy an new power charger.
I should buy a new main battery, one that is more high quality.
I should buy a new CMOS battery. Which I am not sure where it goes, or how to plug it in. There is a round plastic yellow something I see on MOBO. I don’t intuitively see how to take it off, or even what it is. ??? Anyone know where the CMOS battery is for a Librem 13 V2?

And I am thinking of a Power Bank? I am unclear whether this Librem 13 can utilize a Power Bank, or what is involved in connecting it. Does it use the USB A port? Does the computer have to be running Pure OS for it to work? Is the setting to turn on the use of Power Bank in Pure Boot? Does it charge the main Battery at all? Or does it just run the computer for awhile? And is that Awhile like a few minutes of web surfing, or could I install an OS. Or a new copy of Pure Boot?

This problem began when I was trying to update Qubes. Making me think that before I opened the computer, the Librem could be encouraged to function again.

Can any of you tell me about how to replace CMOS?
How the Power Bank works with a Librem 13V2.

I think I should be prepared to have all the options to encourage the thing to start to run of power adapter charger, or charge. which ever it will do. ??? Be prepared to reinstall Pure Boot (basic BIOS/EFI)

To let you shoot holes in my thinking. The replacement main battery I bought was a cheap one from Amazon, who is known for having poor quality goods sometime.

Which might have worked, except both of the OS’s I have on computer are likely corrupted against starting.

As the battery appeared to die while running Qubes. And when I started the laptop one the (already selected) Qube partition. It took a long time to decrypt the hard drive, then fell into Console. Obviously a fault in the linkage of the drive would cause exactly that.

I was concerned about getting the laptop to charge again. As I did not feel I had a lot of time to get Qubes going, and install the file which has the directives to tell the Power Adapter charger to behave towards the battery.

I felt I should try to switch over to the already installed Pure OS on the the other drive.

I read that if the Pure OS was installed in UEFI mode, and the WiFi switch telling it to not use WiFi is off, then the Pure OS might not boot. I dunno? ??? But with a damaged WiFi, seems like I walked into the same condition of not starting Pure OS.

Who votes for me to put this Librem 13 V2 back onto a shelf and let it gather dust, or spend more money on it?

1 Like

Connection/combo recognized through firmware is the most important one (I’m quite sure). Under the particular firmware’s version number charging works or it doesn’t work for/with inserted battery.
head /sys/class/dmi/id/{bios_version,ec_firmware_release}
sudo dmidecode

I have the very same feelings too (or just take directly Debian 12). And, I do have some other thoughts related to inserted battery, power supply or power bank usage there but bringing those thoughts of mine right away (and once I have more time) here will not help if above doesn’t match (as unmatched firmware got you there: no charging of inserted battery).

Please do something (before your CMOS battery dies), as your understanding on what’s going on there is of exact nature, cause recognized by yourself and will be repaired by yourself.