Librem14: Booted from session and can't sign back in

I was just in “settings” playing around with the “zoom” options in “accessibility” when all of a sudden it went to a black screen and I got booted out of the session. I tried logging back in and it just goes to a black screen again and logs me back out. It’s a repeating cycle. I shutdown the machine completely and turned it back on hoping everything would resolve but I can’t login. I unlock the disk, I choose my user, enter the passcode, and boom it goes to black screen and I’m booted again. This all happened just from playing around with the magnifier settings. It’s unreal. What happened? How can I log back in?

1 Like

Librem 14 or Librem 5?

Does the login screen show the accessibility options icon before you choose your username? Does it help to set the default “zoom” before logging in?

1 Like

It does show the accessibility options icon but it doesn’t make a difference if “zoom” is on or not. I still get booted as soon as my passcode goes through. I also sent tech an email so hopefully they will be able to help get me out of this unfortunate situation. I just don’t want to have to reinstall the OS again. It will take so long to get this machine back to the way I had it.

Librem 14 or Librem 5?

Do you have SSH access in to the computer?

Do you have more than one user available on the login screen?

Sorry. I forgot to answer that initial question. Librem 14. And no I was the only user so I can’t try going in through another username.


I can’t open a terminal from this screen. It just really allows me to pick the user and I’m the only user.

SSH from another computer into the problematic laptop? Have you installed and enabled an SSH server on the laptop?

You can maybe (should be able to, I think) drop to tty from the login screen. Try Ctrl+f1 (or f2 or f3) and see if you can get a terminal login prompt.

1 Like

or f4 or f5. Isn’t it Ctrl+Alt+Fn though?

SSH or login tty, the next question will be: what shell command will revert the setting?

If all else fails, there’s always live boot, assuming you have prepared a suitable USB flash drive in advance.

1 Like

I do have a “live boot” but I’ve been avoiding it as it will take me a while to get my system back to the way I want it. I’m still in correspondence with tech support so hopefully they can shine some light as I sent them a video of the situation.

No, the purpose of the live boot - in this topic - is not to reinstall PureOS (i.e. not to wipe out the existing install).

The purpose of the live boot is just to get to a working shell prompt / working GUI so that one can mount the normal root file system and fix the problem.

1 Like

I’m going to give this a shot tomorrow. Thanks for sharing your ideas.

I ran a few nmap scans on my purism devices and none showed any ports whatsoever . . .

I am waiting to bring mine to my professor so we can attempt to crack into it.