Librem14 Freezes Up Constantly

Hi all -
I’ve been testing a Librem 14 that I’m considering buying from a friend. Long story short. I updated all the software since it hadn’t been touched in a year or so but the machine’s been freezing constantly.
I’ll be in a browser session and it’ll just lock up. Often just opening a new tab will cause it to hang indefinitely. I’ve tested four different browsers – Web, Firefox, Chromium, and Chrome – but it doesn’t seem to matter.
After the software and recommended OS update, I noticed a missing firmware message during the boot-up process. After that I re-installed PureOS. Same results. The latest thing I’ve tried was updating the EC firmware. ( Apparently I didn’t nail all the steps properly so that’s still in progress. I really like the machine but I can’t justify the purchase in its current state. I’m hoping some of you can provide guidance.
version: 2021-06-04_ef9fd3c

I think that message is irrelevant.

What boot firmware does it have (Coreboot or Pureboot, not asking about the EC)? Is that up to date?

I would persevere with getting the EC firmware up to date too.

If still under warranty, I would contact

Thanks for the input. I updated the Coreboot firmware this morning. It’s already froze a few times since the reboot. :frowning:

Can you try a different stick of ram for a bit? Did you already wipe and reinstall the OS?

Yes I already re-installed PureOS twice. And by RAM stick do you mean opening up the machine?

Yeah, constant random freezes sounds like a hardware problem for sure. Swapping out the ram and/or just running a single ram module if there is a two might help narrow the problem down. Some live linux disks also have a memtest option on boot, but that is slow and takes a long time.

Post the output of sudo dmesg -T

You can find there useful hints, specifically about hdd/sdd issues.

You can also check /var/log/syslog for issues.

Thanks for that…I see a couple of firmware fails from the output. Realtek and Atherton are the only things in red. I’m not knowledgeable enough to flag anything else. Question. Since I now have the later firmware, (7/27 build) if I reload the OS will it keep the latest build? My next step is Purism support.

Might be a good idea to put the kill switches in the “off” position, in order to narrow things down a bit.

Hey, I’ve been dealing with constant freezes as well, both on PureOS 10 KDE edition and now on Kubuntu (in fact switching OS was my way of dealing with the problem but it didn’t work). Here’s what I’ve managed to gather so far:
Freezes happen during normal work (web browsing, working with LibreOffice Calc, watching videos with VLC). There’s no specific pattern to what I do. The only thing is that the web browser (Firefox - from apt, not from snap/flatpak) is always running. Freezes happened completely at random and do not depend on amount of load. I tried running several videos at the same time locally and in FF, running GPU benchmarks, but I couldn’t find a way to reproduce it consistently.

I looked at /var/log/syslog and the latest messages before the freeze are:

Oct 30 17:56:51 nikita-librem-14 kernel: [  347.322106] i915 0000:00:02.0: [drm] Resetting rcs0 for      preemption time out
Oct 30 17:56:51 nikita-librem-14 kernel: [  347.322812] i915 0000:00:02.0: [drm] *ERROR* rcs0 reset request timed out: {request: 00000001, RESET_CTL: 00000001}
Oct 30 17:56:51 nikita-librem-14 kernel: [  347.334076] i915 0000:00:02.0: [drm] GPU HANG: ecode 9:1:85dffffa, in Renderer [1834]

Looking up the issue didn’t yield any results yet, except this webpage:
I have not yet tried any of those proposals yet but I will and post back if they worked.

One other thing to know is that for me freezes almost never happen when I am on AC. When I am on my battery, they can happen from time to time and they do happen much more often when I use VLC.

I am running PureBoot, by the way. I am not on the latest version of it and EC firmware yet, so I will update and report back.

Make sure that: librem_ec_acpi is installed. Also upgrade PureBoot and EC. Try again, if the issue persist then monitor the CPU, KERNEL and RAM remotely to track overflows. ssh.

ok fisrst thig:
upgrade pureboot
make sure kernel you are running matches kernel in pureboot.
there were issues with intel gfx and kexec already.
kde uses more 3d rendering and that exposes wrongly passed memory map to intel gpu
if you still excpirience problems aftter above , drop pureboot in favor of coreboot

Thanks! Just for the record, is librem_ec_acpi and librem_ec_acpi_dkms the same package? I only found the dkms binary to install.

Hey, thanks! I updated pureboot and firmware now as well as installed librem_ec_acpi-dkms package. Overall I see snappier performance and so far no freezes when I am on the charger. I haven’t tested being off-charger yet, will do soon.

What’s the way to check the kernel version in pureboot? Is it just uname -srm in the recovery shell or are there other methods?

It is librem_ec_acpi_dkms my mistake.

Okay, so since I upgraded my firmware, installed librem_ec_acpi_dkms package there were no freezes, except now, which happened with the same error. I was watching a video stream with a bunch of other apps open in background.
Overall, it looks like the situation has improved, as I wasn’t getting any crashes even when not charging, which used to be not the case before.
So, I will monitor the situation further and ses if anything else can be done.

For the record, I checked the kernel version in Pureboot and uname -r gave me version 5.10.5. My kubuntu kernel now is 5.15.0-52-generic.