Librem15 Source List

I added a source for RIOT so I can add the chat capability. I went to the RIOT site and it gave instructions to add the repository. The information was out of date and it would not allow me to do sudo apt update.

Below is what came back when I attempted to update.

Ign:1 green InRelease
Hit:2 green InRelease
Err:3 green Release
404 Not Found [IP: 2606:4700:20::6819:2469 443]
Reading package lists… Done
E: The repository ‘ green Release’ does not have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

That being the case, I attempted to remove the repository in the source list, but it does not show up. I used gedit /etc/apt/sources.list. The only source that showed up was deb green main.

If anyone has an insight as to why I cannot see nor remove the repository, I would be greatly appreciative.

Additionally, if anyone has a set of installation instructions, I would be ecstatic.

Thank you.

Riot is in the snap store. that would be an easy way. Haven’t tried but should be:

sudo apt install snapd
sudo snap install riot-web


I’m assuming you looked at the instructions here:

First things first, there’s more than one sources.list file, in fact /etc/apt/sources.list is the “main” file but any additions should ideally be added in individual files in /etc/apt/sources.list.d/

This is what the instructions at that link provide, and you will find the source here:

Second, the error:

This indicates that you tried to mix release names between Debian and PureOS :wink: This is a side effect of the snippet at the website, which gathers the release name from your own system - in this case, the release name in PureOS is “green”, which doesn’t exist in debian and so doesn’t exist in the repository.

I suggest editing that riot-im.list file and replacing “green” with “stable”, “stretch” or even “buster” and seeing if one of them works.

I really appreciate the information from the forum. My challenge with changing with replacing “green” is, the repository does not seem to show up. I can definitely go back and take a look though.

patrixl: I appreciate the info. I tracked down the file and removed it. Thank you.

i hate to be a bother. I installed RIOT via snap. Hate to ask…how does one get the program to start. Has to be run in the terminal correct? What is the exact syntax?

Simply go to your installed apps and find riot. Or hit super and type riot. You’ll see the icon popping up, all done. Enjoy!

For what it’s worth, Snap is a Canonical project intended mostly for Ubuntu. PureOS (and to some degree, the entire GNOME desktop) are focused more on Flatpak.

Riot is also available as a Flatpak, which you can download here:

i appreciate everyone’s help. I was able to get the program running :slight_smile: