Librem5 date/time and updates issues - now unusable

How do I change the date/time which is currently showing year of 2061 !
The gui option is greyed out.
cli timedatectl shows: ntp service active.
It has wifi connection ( confirmed ) yet does not update ?

It says I need to download updates but when it tries gives the following errors :
…deb10u1 is not available…the certificate is not trusted…could not handshake. ?

if your phone think its 2061 and the TLS certificates expire in 2022, your phone won’t trust the certificates

You have to configure the good current date in settings >> details >> date & time

Disable automatic date & time, then enter the good date


thanks for the reply. I can no longer find the settings button so I used the cli. Now the date and time is correct, when I go to update the software I just get the error : E: amber-security/main arm64 libzsdtl arm64 1.3.8+dfsg-3+deb10u1 is not (yet) available (404 not found [IP: 443]). - typed from the screen so maybe a typo(s).

any ideas ?

I used sudo apt-get upgrade and it works. not sure what the gui reads. The problem is fingers are too big for keyboard - can you link a bluetooth keyboard to the phone ?


I went to see what apps to download and tried to download the karting game - but it seemed to hang - ie. stayed at 0% install. I cancelled. I then tried the updates and that worked this time, I clicked restart and the phone no longer seems to work.
I pressed the button one the side, it shows the librem5 sign, the light top right is red. the screen goes blank and I cannot do anything.
Is there a button sequence to do a reset ? I don’t have anything to save.

You can reflash the phone using these instructions


If I received that error from apt upgrade then I would start by doing apt update

Yes. I have done that. It works.

Heck, you should be able to plug in a vanilla USB (full-sized) keyboard, providing that you have a suitable USB-A-to-USB-C adapter - and I can confirm that that too works!

1 Like

Finally got round to flashing the phone. So far it seems ok and the time/date issue before is gone.

1 Like