Librem5 dont change the language

with qemu, on the Librem5 terminal I write sudo nano /etc/locale.gen
then change the desired language
then sudo locale-gen
the system shows me the processing and in the language change preferences but … I still have the English language.
I have tried 3 more times but the result doesn’t change.
Do you know if something has changed?
Thank you and greetings

Are you saying that this did previously work correctly?

yes, previously work correctly.

Are you trying to delete the English language or are you trying to change your locale to something other than English?

i am trying to change from english to my language.

I think this command (which is a script, so you can view it easily yourself) only processes locale definitions in order to make them available in the system for selection. (Hence you would not delete English, you would just ensure that your desired language is not commented out.)

Actually selecting a locale for yourself is different.

Have you tried selecting a locale using the GUI?

Failing that, I think you need to
cat /etc/default/locale
to see what’s there and then
update-locale LANG=whatever LANGUAGE=whatever

then logout and login again.

To be honest, just having e.g.
export LANG=whatever
somewhere in your login script should be good enough.

PS Don’t forget that, depending on your SSH config, if you SSH in then SSH may propagate this kind of setting from the source host to the destination host.

Thanks for your help but by running the commands you have indicated to me it appears that there is the language I want … but the system continues to show all the applications in English!
however now I download the image from the site and try again. Let’s see if anything changes.
Hello and thanks

Even something like the following?

date +%A

I just edited /etc/locale.gen to uncomment fr_FR.UTF-8
did locale-gen
then the output from
env LANG=fr_FR.UTF-8 date +%A
date +%A

Trop facile. :slight_smile:

Maybe the language pack got removed somehow…?

Well, I don’t know what happened but now, after downloading the new image, everything works and the language is the desired one.
Thank you and good day.

1 Like