Librem5 import contacts from file


on Librem5 contact app I don’t see any option to import contacts from file.
Is there any way to import contacts from cvs file ?
Any plans to have sync tool between Librem 13/14… laptop and Librem 5 phone (photos, Music, contacts …)


1 Like

Hello and welcome :slight_smile:

There is something about contacts in the community wiki, here:

Does that help?

1 Like

If you mean from a .CSV file then no, not without some work. There is no standardised representation of a contact as CSV.

The documentation linked in the previous post covers importing from a .VCF file. Importing from an .LDIF file is easy enough too.

That would depend on what software is being used on the laptop.

thanks for quick reply. that was helpful
Happy user of Librem5 :slight_smile:

1 Like


I would like to know where the contacts are stored in Librem 5 and how to back them up for security (and where?).
I have a thousand of them so I don’t want to lose them!

Also, I read on this forum that you can easily import contacts in LDIF format. Has anyone been able to do this and import the phone numbers as well? (When I imported my contacts in VCF format I only got the email addresses: the phone numbers were not imported!?? !).

Finally, does anyone have any idea when the “Bizantium” Update will be available?
And do we know if this update will allow you to call a contact by clicking on his number, which is currently the most missing feature in Librem 5?

Thanks in advance!

I have. [MyL5] Australia/New Zealand

Guess. NB: Guess /home/purism/.local/share/evolution/addressbook/system/contacts.db

That appears to be an SQLite database so I suggest researching on the internet how to back up such a database.

The one approach that I would not take is just to copy (cp) the file - because I can see that the file is ‘open’ (lsof) - but maybe it is not opened at boot and so maybe would be safe to copy in that situation.

My backup strategy (still to be written and tested :slight_smile:) will be to back up the entire eMMC drive to another computer (using Jumpdrive). So that will pick up this database and everything else.

This question confuses me. When I go into the Contacts app and look at a contact, below the person’s initials and name, I see a list with entries of the format

contact-type contact-number sms-icon phone-icon

one per line, where contact-type is e.g. ‘mobile’ or ‘work’. (Then the Note field is displayed below that.)

For example: Mobile 0424242420 sms-icon phone-icon

Clicking the phone-icon causes it to start a call to that number (contact-number), which is the behaviour that I would expect. (Clicking the sms-icon starts Chatty in order to send a text message to that number.)

The layout could definitely be improved but it does at least basically work.

(A lot of the contact types did not import correctly e.g. show up as ‘other’ but in fixing that, I don’t have to enter the phone number, just change the contact type from ‘other’ to e.g. ‘home’. This may have been a problem in the original data.)


Hello and thank you for your answer.

As far as I am concerned, the “mail” and “chat” icons work quickly and perfectly.
Only the “phone” icon does not work.
It is very strange because the “chat” works with the phone number (at least it seems to me…).
I would like to point out that when I imported my contacts, only the email addresses were imported. I had to add the phone numbers myself, contact by contact. So I think the format is good.
I even tried to replace the first zero of the number by the international code of my country (France = 33) : it didn’t change anything.

Should I uninstall the “Contacts” application and reinstall it?
But in this case, what will happen to my contacts?
Won’t they be deleted, lost and have to be re-imported? Which would not be at all convenient for me because I have more than a thousand of them.

Thanks in advance.
Thank you in advance,

Even for a Contact that you added yourself?

What does “does not work” mean? So the icon is there but when you click on it, nothing happens? You get an error? Any message logged? You may have to contact Purism support.

Can you make calls at all e.g. if you dial the number yourself?

For the numbers that all imported automatically for me, I did not include the country code (AU = 61). So just leading zero, area code, local number.

I would recommend against doing that - for the reason that you mention. You may lose all your contacts and if you don’t lose all your contacts then the problem may well not be fixed.

You really need an Export / Import function within the Contacts app - but I can’t see one at the moment.

You could try reinstalling the “Calls” application. That might be safer. However I would suggest investigating more about what is going wrong first.

Yes, the phone icon is there (in the « contacts » application) but when I click on it nothing happens, while when I click on the “mail” and “chat” icons, everything works perfectly.

When I dial a number myself in the “phone” application, it works.
It also works when I click on the “phone” icon in this application (the icon next to the number of a person I called or who called me).

Only in the “Contacts” application does this “Phone” icon not work.
This is very annoying because it is a very useful feature for a phone!

Sounds like it could be this issue:

But that was supposedly fixed a month ago.

Have you installed the latest updates? (Bottom-right corner in PureOS Store, or using sudo apt update && sudo apt upgrade from the terminal)

Has the fix been released though?

Good point, looks like it’s still calls version 0.2.0 on amber-phone with the latest updates:

purism@pureos:~$ apt list calls
Listing... Done
calls/amber-phone 0.2.0 arm64

Then that fix has not been released yet, at least not for amber-phone. Maybe it is released for byzantium, I don’t know.

Hello I replied via email but I will leave the same reply here as well.

This issue will be solved in the next version of pureOS Byzantium, as a workaround if you add the country prefix to the phone number them the call button from the contacts app works.

To import contacts from a vcard file (.vcf) you can install librem5-goodies application. The feature to add contacts from a csv file is being worked on in upstream GNOME contacts.

Hello João

It’s getting stranger and stranger:

I had already added 33 (but not +33) to some numbers to test but it didn’t work.
I also tried to update but it didn’t seem to work.

After your message I added +33 to my wife’s numbers (landline and mobile).
The call worked on her mobile but not on our landline.

I then did the same test with a friend: both calls (landline and mobile) worked.

Then I tried the update again and this time it worked.
But, since this update, the calls from the “Contacts” application do not work anymore!!?!!!

The mystery thickens…

I take advantage of this message to ask you if you know approximately when the “Byzantium” update will take place.


What is the correct number :
+330955364534 ?
+33955364534 ?
+33 09 55 36 45 34 ?
+33 9 55 36 45 34 ?

1 Like

Now I get this message in the « Calls » application : « Can’t place calls : No voice-capable modem available » ??!!??

The problem is solved: I had made a mistake with the phone numbers of my house! Sorry to have wasted your time.
With +33 everything works fine.
However, I think it should be made clear to the buyers.

Have a nice day,

1 Like

Strangely though I never include the ‘+’ and country code (that would just be clutter for me) and it has always worked.

hi all i installed the librem5-goodies and used the contacts importer to import a .vcf file however no contacts are imported.

i used the same vcf file to import contacts in waydroid and all contacts show up.

can anyone please help ?

Did you get an error message or just no contacts imported?

What version of .vcf file?

the version is v3. i dont think so i got any error message.