LibremKey is not lighting up - locked out of computer

My LibremKey is not lighting up today when inserted to the librem14. I used it fine yesterday but it has done this in the past and then starts working again after a while of doing nothing.

Troubleshooting steps I’ve taken:
Rebooted many times
Laptop is plugged in
Tried both USB ports
Tried a usb-c to usb-a hub
Usb mouse plugs in and lights up so power is good

I’m at work and I really need to find a solution to get in.

Additional: I just updated the system yesterday before shutting down and I recall that this was also done last time I had this issue.

If you are okay with bypassing boot firmware tamper protection check:

  1. Unplug the Librem Key.
  2. Select “Ignore error and continue to main menu”.
  3. Select “Options -->”
  4. Select “Boot Options -->”
  5. Select “Ignore tampering and force a boot (Unsafe)”.
  6. Select “Yes”.
  7. Select your operating system.

If you just updated the system (depending on exactly what changed) then … because the Librem Key can’t tell whether a change was legitimate or illegitimate … it may be that you have to re-sign in order to accept the change as legitimate.

As far as I can tell, the way to apply kernel (and similar) changes is - without losing custody of the laptop -

  • apply kernel (and similar) changes
  • reboot
  • re-sign

That way, when you come to boot up after a period where you have not monitored custody of the laptop (such as overnight when you are asleep), if the Librem Key highlights any change then the change is genuinely tampering and you should consider the laptop compromised (at least theoretically speaking).

1 Like