LibreOffice not loading after update yesterday


#5

LibreOffice suggested resetting my user profile, that is, starting in safe mode (run libreoffice --safe-mode from terminal window). No errors, still nothing. Removed and reinstalled LibreOffice from the gnome Software manager, and now it is working.


#6

Hello ALL
Same issue this morning after hour of search I finally found a way to open it in terminal
/usr/lib/libreoffice/program/soffice.bin &

In my syslog file libre office tell me the same thing like Amarula profile error

apparmor="ALLOWED" operation="exec" info="profile transition not found" error=-13 profile="libreoffice-oopslash" name="/usr/lib/libreoffice/program/soffice.bin" pid=8698 comm="osl_executeProc" requested_mask="x" denied_mask="x" fsuid=1000 ouid=0 target="/usr/lib/libreoffice/program/soffice.bin"


#7

this …


#8

It’s an already reported bug related to AppArmor, see https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=918499.


#9

Yess!!! That’s it, thank you!

$ sudo apt purge apparmor*

updated and upgraded, then restarted my computer and now it works just fine.


#10

@djoow Thanks for the command line workaround:

$ /usr/lib/libreoffice/program/soffice.bin

This saved me some trouble, because I had to switch to trusty Xubuntu for LibreOffice while my PureOS-based Librem 15 was wrecked. This is getting ridiculous, and I agree with @beFree that the rolling release scheme is not very stable because there’s insufficient testing, a point I’ve made before. Looks like Debian “testing” should be renamed Debian “untested”.

Thanks to @Ricky for the link to the AppArmor bug report and the incredibly hostile response. They tried to kill the messenger, who brought news of their buggy programming that wrecked an untold number of people’s systems. Nobody’s perfect, and bugs exist, but that’s why we TEST.

I started to dig into apparmor and its complex documentation, but I couldn’t even install apparmor-utils because of broken packages that are unfixable at the moment. Talk about a Catch-22!

I was afraid to purge apparmor like @McShine did, because of unknown side effects and vulnerabilities, but the direct command line invocation of LibreOffice works fine without messing with apparmor.

Maybe it’s time for Purism to dump the continuous rolling release and move to a release schedule that gives more time for testing, such as monthly or bimonthly. Even every 2 weeks would be an improvement. Thoughts?


#11

I run debian teting on my other machine. It is updated and work just fine. maybe it is a problem with pureOS, which is far behind debian testing. For example Debian testing is on kernel 4.19.


#12

I have the same issue.

FYI, I opened a task for the apparmor-utils item a couple of weeks ago. It was broken by the python3 update to 3.7, and the required, broken package is one modified by Purism.

I think the update process is simply broken. Some of the errors I am getting demonstrate little or no testing or dependency checking. Saying “wait a couple of weeks” for packages to propagate is not a good answer.


#13

This feedback is being taken seriously and the status of the rolling release is under review. Please know that we want the same stability as you folks do.


#14

So after I reinstalled LibreOffice yesterday it was working… and this morning it has stopped working again. This is like being back on Windows darn it. Thanks again for the AppImage suggestion, at least it is working. And thank you to all the folks at Purism for looking into the cause of the issue, I for one am willing to wait for a proper fix in the presence of a usable workaround (AppImage).


#15

For those that do wish to remove app armor all together, I was able to resolve the issue by removing the following entries (lines 89 and 90) in /etc/apparmor.d/usr.lib.libreoffice.program.soffice.bin:

#include <abstractions/dri-enumerate>
#include <abstractions/mesa>

I restarted apparmor and it LibreOffice was able to open. I have performed some cursory exploration on what the consequences of removing those entries might be and have yet to find anything as of yet. And a friendly reminder to backup up the file before writing any changes to disk!


#16

I think we’ll be better served with a stable release with bug fixing updates. Purism is looking into to moving to this in upcoming releases.


#17

Thank you. This made it work.

I actually do not see either of these files in the abstractions directory on my system. Maybe that is what is wrong.


#18

I’m glad to hear that it helped. I have had to edit the file on multiple occasions as the configuration has been overwritten. Of course, removing those lines did restore access to LibreOffice once again. Just so you might be aware.

I hope this gets fixed soon.


#19

@Amarula did you try invoking LibreOffice from the command line? It works perfectly for me and I didn’t have to install, deinstall, or modify anything. Well, for convenience I did make an alias in my ~/.bash_aliases:

alias lo="/usr/lib/libreoffice/program/soffice.bin"


#20

@jeremiah a stable release schedule with bug fixing updates sounds great. A release every six months would be fine with me, though maybe every 2 or 3 months would be better for Purism. What would be the optimum for Purism?


#21

Yes, I did try using the command line, and it didn’t make any difference for me. Editing the app armor looks interesting but I don’t think I am going to risk the headaches given a workaround (AppImage) that is already working for me.
And thanks everyone for sharing your thoughts and information.


#22

I was having the same issue for the past few days. I saw that there was an AppArmor update today so I upgraded and it seems to be working now!

To be clear, what I had done before is a complete uninstall of LibreOffice on my system ($ sudo apt purge libreoffice-common) and I have not tinkered with AppArmor or its profiles. I just upgraded after seeing the recent AppArmor update, then reinstalled LibreOffice from the repo.

$ sudo apt update && sudo apt upgrade -y
$ sudo apt install libreoffice-common --install-suggests -y
$ sudo apt install libreoffice-writer libreoffice-calc libreoffice-impress libreoffice-draw --install-suggests -y

e: @mike16437 mentions that a complete uninstall of LO is not required to get it working again! Before resorting to a complete uninstall, please try a simple $ sudo apt update && sudo apt upgrade. Hopefully, that will resolve the issue without having to uninstall either LO or AppArmor.


#23

Didn’t even need to uninstall LibreOffice, just did the sudo apt update && sudo apt upgrade -y and it’s all working again! Thanks!


#24

This issue does seem to be fixed after updating this morning.

@nochelibre, that apparmor-utils bug also seems to be fixed. The dependency was changed and I could install this package.