Linssid or equivalent app

I installed linssid, similar to WiFi Analyzer on Spydroid, but it fails to start on Mobian (I suspect similar behavior on L5) due to a failure to initialize the xcb qt component. It seems this may be caused by missing X11 stuff, because… you know, Wayland.

Has anyone either overcome this, or found a good replacement app?

What do you want to “analyze”? Sorry not familiar with that app.

Apologies. It monitors 2.4 & 5 GHz and displays SSIDs and their channel assignments. Tool optimizing your WiFi, enabling you to put your access point in a quiet zone.

sudo iw wlan0 scan

You will probably want to pipe through grep to pick up the things you are interested in, since it produces a lot of information (most of which is too obscure for me).

Adding: e.g. sudo iw wlan0 scan | grep -E '^BSS|freq:|SSID:|channel:'

1 Like

That looks really promising (gotta love bash!), but it tells me that iw is not found. So I used apt to install it, but it said that the newest version (5.9.3) was already installed and was now set to “manually installed”. :thinking:

I just tried iwconfig on Mobian@PinePhone and wondered that it’s only found with sudo.

However I tried to bring the wifi card into monitor mode and it seemed to work. I used the method from this article:

I did not go any further, yet, but if it really works it opens up possibilities for sniffers like kismet.

1 Like

OK, you got me. I should have mentioned that I may have had to install it (too long ago to remember).

I have version 5.0.1-1 though.

Are you on Byzantium? I’m on Amber.

Also, yeah needs sudo so I edited my post to reflect that.

Sudo? Should have known! :man_facepalming:

I really like WiFi Analyzer, and would probably like linssid, but iw will work fine for the occasional setup or troubleshooting.

I have found a way to run Linssid. It is just that pkexec, which for some reason is used in the Linssid package, is not a proper way to run GUI applications from root. It is actually explicitly written in man pkexec. Another problem is that for some reason Linssid does not detect that it can run natively on Wayland.

Here is a (probably ugly) workaround. Just create ~/.local/bin/linssid-pkexec with following content and make it executble. (It is a modified version of /bin/linssid-pkexec.)

pkexec env QT_QPA_PLATFORM=wayland XDG_RUNTIME_DIR="$XDG_RUNTIME_DIR" "/usr/sbin/linssid" "$@"

This will allow to start Linssid by pressing its icon in app list.