Live usb doesn't appear as option in boot menu


I want to install Ubuntu on my new Librem13, so I’ve done the following:

  1. downloaded Etcher and a Ubuntu iso, on another machine (macbook);
  2. used Etcher to flash the iso to a Sandisk 16g USB (which coincidentally wasn’t recognized by the macbook, the usb I mean); – Etcher reported a successful flash
  3. turned off my Librem13, plugged in the drive, turned on the Librem, and pressed esc, which brought me to the boot menu
  4. at this point, I see no option to select the USB with Ubuntu iso; the only options are:
    “PureOS GNU/Linux
    Advanced options for PureOS GNU/Linux”
    and then 4 “Memory test” options

As an aside, when booting into PureOS with the drive still attached, on a couple occasions, my trackpad didn’t work.
Also, I initially tried installing Etcher on my Librem, but it said no application could be found.

I’d just like to run Ubuntu on my Librem13 for now (I’ll play around with PureOS another time).

Can anyone help?

Does Experiences with Ubuntu 18.04 (Bionic Beaver) on Librem 13v2? help?

What Ubuntu exactly did you download?
What BIOS (firmware) is on your Librem 13?

The BIOS on the Librem is 4.11-Purism-1, Revision 4.11 Firmware Revision: 0.0, and I downloaded Ubuntu 20.04 LTS.

An answer’s not apparent to me from the post you linked, since I can’t choose the usb stick to boot from (the option doesn’t appear at boot menu). The USB device is recognized once PureOS has been booted into.

Since you said that you downloaded and created the Live Boot USB on another computer, can you verify that the USB boots correctly on that computer or on any other computer?

OP said they downloaded a vdi. I would suggest downloading an iso file and using that instead.


In that case, I would be asking “from where?”. Is it a verified download?

But, yes, just the regular .iso, please e.g. ubuntu-20.04-desktop-amd64.iso


~$ sudo dd bs=4M if=/path/to/ubuntu-20.04-desktop-amd64.iso of=/dev/sdX status=progress oflag=sync


if the computer being used to do this is running Linux. The “another machine” referred to may be running Windows.

would you happen to know if using a TLC (tripple level cell) SSD as the bootable-medium with a higher block-size would result in a snappier live environment ? what about MLC ?

sorry! I meant iso… (downloaded from
original post edited for clarity/detail

I just checked that the live usb appears in the osx boot menu on my macbook; it does, as an EFI

So it comes back to … do you have any independent means of verifying the bootability of the USB flash drive? (A Macbook is probably not the best choice for that testing.)

Do you have a DVD burner that could directly use the .iso file? i.e. as an alternative to a USB flash drive at least until you can get it booted.

well, I’ve just implemented a partial means of gauging the likelihood that it’s an issue with the usb flash drive bootability: I’ve just tried with two additional USBs, and got the same result (no option displayed at boot menu except those listed above).

more precisely, I used Quarnero’s dd command above, to burn the same Ubuntu ISO as I had before, once on another Sandisk usb device, and lastly on a memorex usb device.

Could reinstalling PureOS possibly help, e.g. using the Librem Drive that shipped with the laptop? Otherwise, are there other avenues to troubleshoot along, other than trying to verify with absolute certainty that it’s not a problem with my usbs?

As an aside, before doing all this, I installed some Haskell-development-related dependencies (Haskell Platform, as well as some foreign c libraries), to try to get a library (Gpipe 2) running, and was getting segmentation faults upon execution (whatever that possibly indicates, and which contributed to my decision to swap to a more familiar OS).

1 Like

I have been using Linux for a few years, but don’t consider myself an expert. But the menu you described sounds like a GRUB menu, not a boot menu from the BIOS.

The boot menu from the BIOS should list drives, not OSes.

I may be wrong and making myself look like a fool, though. :slight_smile:


wow, @CyborgPenguin thanks for your reply/taking the risk on something simple! – I got through to the boot menu, and am currently booting from Hard Disk :slight_smile:
I’m not sure what went wrong before… I definitely pressed esc after power on, but maybe held it too long, or pressed it too late?.. anyway, I don’t expect further issues, but will post if/when my installation completes.
thank you, all!
edit: I’m booted up!


Swissbit U-56n sequential read is up to 190 MB/s. But others, cheaper ones like Apacer EH353 with Toshiba MLC might be snappy enough. For live environment I’d go in this direction, if it is about 4-8GB USB Flash Drives, but didn’t test any of those.

1 Like

that’s how i learn :slight_smile: and i reserve my right to be wrong and look like a fool … those that don’t take risks generally don’t evolve …


If your BIOS supports it then there should be a way of bringing up a “boot disk menu”.

Once you have selected the boot disk, BIOS will boot from that disk - and what gets booted is typically GRUB, and GRUB will present its own menu (if so configured).

All as you say.

One minor complication … the GRUB menu could give options for booting an OS from other disks.

That can get messy though if you are just testing / messing around / playing around. You don’t necessarily want boot options for another disk to be permanently recorded on the GRUB menu - and you don’t necessarily want the interdependencies between an OS installed on one disk and an OS installed on another disk.

Maybe re-read the first link in this topic. :slight_smile:

However as that post is 2 years old, it is also possible that Purism has subtly altered the exact BIOS behavior in the meantime.

it does … i have observed this to be the case with most BIOS or UEFI (modern proprietary implementation)

if you are using a usb-thumb-drive or any other solid-state-drive LIKE storage-medium it will list it as both a UEFI option and as non UEFI … this is confusing because it they both work then list ONLY the one that is the MOST likely to give a succesful boot/install

if you’re on an UEFI platform it usually makes sense to boot in UEFI mode > esp > /boot/efi