Lockscreen disable


there was a thread long long ago in which was discussed to bypass login screen and lockscreen after a adjustable timeout.

For me I want have ONE time a login screen after a start/reboot and after that no more lockscreen pin .

Anybody has found a solution for this?

1 Like

I’m not sure if Automatic Login on Boot is what you are looking for?

1 Like

It is somehow possible.

You can disable the lock screen completely and after that what you descripeb will work.

This can be done trough System Settings and it was introduced in Phosh 0.25

But unfortunately suspend will still lock the screen so you can’t use suspend if you don’t want to see lockscreen.

1 Like

How can you do this?
In my system settings that option is greyed out (I’m running Phosh 0.29.0 and have the latest updates installed).

1 Like

System settings → Privacy → Lock screen

There should be option “Automatic lock screen” which you can toggle off.

I am using different language so I am not 100% sure how those settings are written + I am writing this from my memory but it should be there :smiley:

1 Like

:+1: Indeed, that’s another way of achieving the OP’s goal.
I was looking at settings → Users → Automatic Login
But like I mentioned before. That option is disabled.

1 Like


  • disable Lockscreen
  • disable suspend

Let the phone untouched for 10 minutes, screen is off.

Switching the phone back to on gave me the lockscreen and I have to enter the PIN again as before :frowning:

1 Like

So the settings you applied are not doing anything.
Weird, maybe an excpert or support can help you. My knowledge is too limited.

1 Like

You cannot disable the lock screen, so the next best option is to adjust the Automatic Screen Lock Delay.

Does also nothing useful. Screen goes black and 10 minutes later the lockscreen with PIN input appears after pressing the power-key.
There must be something “hard-coded” in phosh that does not behave like standard Debian-Gnome.

1 Like

Strange because the System settings option does not work. Never noticed that before.
Luckily this did the trick for me:
gsettings set org.gnome.desktop.screensaver lock-enabled false

Nope it did not work, I had delay enabled xD.
I will try now:
gsettings set org.gnome.desktop.screensaver lock-delay 99999999

This seems to work. Use this xD


You may need to restart your phone for the settings to take effect.

1 Like

Also after an restart the lockscreen with PIN reques pops up after phone has switched off the screen for more than some minutes.

Does Your solution work on Your phone?

I fear that Purism has “greatly” programmed own solutions in Debian/Gnome. And nothing about this seems to be documented nowhere???

1 Like

Guido fixed this:

But it is not yet merged or landed in any Phosh release. So if you want to try you need to build phosh yourself :slight_smile:

1 Like

If there is a howto about building :wink:

Thanks, seems to be of more people have an interest on this issue…

1 Like

I will do my very best :wink:

1 Like