Making a Non-working App Work

So, I tried to install ConvertAll, a unit conversion app. Didn’t launch, so I tried to launch in terminal:

purism@pureos:~$ convertall
qt.qpa.plugin: Could not find the Qt platform 
plugin "wayland" in ""
This application failed to start because no 
Qt platform plugin could be initialized. Reinstalling
 the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, 
minimal, minimalegl, offscreen, vnc, xcb.


Is it as simple as installing one of these plugins to get the app working? If so, which?

$ QT_QPA_PLATFORM=xcb <command>

will run it with X plugin under Xwayland

1 Like

Edit; @ruff beat me to it :slight_smile:


QT_QPA_PLATFORM=xcb DISPLAY=:0 convertall successfully launched the GUI. Thanks for the help!

Sounds like this step won’t be necessary when byzantium arrives on the L5, is that correct?

Dunno, i didn’t try yet any qt apps on my byz, and now when I tried i found it discharged, so put on a leash again.


In the meantime, I’ll just use as a Web App. It works well with the screen.