Making Wi-Fi 6 AX201 work in PureOS


I own Dell Latitude 5420 and I have installed PureOS. Everything works fine except Wi-Fi and updates of GNOME. I tried what I could, but nothing really helps… Could you help me please? I would like to change my Windows and macOS software! : - )

So… “sudo apt update” and “sudo apt upgrade” helps but then… GNOME and PureOS update can’t be performed. When I force it by “sudo apt-get full-upgrade” then, after restart, my Ethernet doesn’t load.

*-network:0 UNCLAIMED
description: Network controller
product: Wi-Fi 6 AX201
vendor: Intel Corporation
physical id: 14.3
bus info: pci@0000:00:14.3
version: 20
width: 64 bits
clock: 33MHz
capabilities: cap_list
configuration: latency=0
resources: iomemory:600-5ff memory:605529c000-605529ffff

0000:00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (13) I219-LM (rev 20)
0000:00:14.3 Network controller: Intel Corporation Wi-Fi 6 AX201 (rev 20)

What can I do to make my Wi-Fi card working and how can I update GNOME without a problem?

Thank you for your time…I hope to hear from you soon! : - )

Please take a back and fourth look at this thread (should help you to resolve … your request).

1 Like

Pure OS is not compatible with intel card, so you need to buy a compatible card or install blobs over pure os to get work ur current wlan card. like @Quarnero say Making Wi-Fi 6 AX201 work in PureOS


Thank you guys for your help! It worked, and the Wi-Fi card is now working. After fixing the Wi-Fi, I have installed the remaining updates, but unfortunately… they made Ethernet not detectable. What could be the problem?

By the way, I have the impression that installing LibreWolf is very hard to do. Are you also experiencing these difficulties? I tried installing LibreWolf with Alien but to no effect. There is also an issue with dnf and I can’t install yum - only AppleImage helped to get the application running.

Is it really that hard to use PureOS?

And of course for future people who have a similar problem - I found exactly this part helpful in fixing Wi-Fi:

Thank you guys again! This is just the beginning of everything,

1 Like

As your laptop managed to survive :face_with_head_bandage: without damage some of my posts, in order to install (and use) LibreWolf in its original form (please remove your previous types of installation) on PureOS 10 (that I’m not really familiar with), what I’m aware and like to share here is that there exist two strict rules: LibreWolf package needs higher versions of to it related dependencies and those do not exist (probably or not yet) within PureOS Byzantium repo. Secondly, and related to the first, as I recall, use only: sudo apt install librewolf every time when LibreWolf browser needs to be upgraded.

When above well understood (especially not to use: sudo apt upgrade during here described LibreWolf install steps on PureOS) we can proceed to what’s needed to be done:
a. visit the official ( LibreWolf link and execute first two commands (exactly please),
b. sudo apt update − check if everything ready,
c. add temporarily (in addition to the one within a.) to your main sources.list this repo: deb bookworm main,
d. execute manually: sudo apt update && sudo apt install librewolf,
e. disable bookworm main repo until you reach the point to upgrade librewolf package again (do not enable it if not necessary), as mentioned already, “upgrade” it only with: sudo apt install librewolf.

Hope this helps. Please inform us back, post how things worked for you (if my advice works for you) as I didn’t proofed this recently (and I usually forget important things anyway :lying_face:).

1 Like

Thank you for your time! I’ll try installing LibreWolf using your method and will get back to you tomorrow as soon as I know more about it. I will of course edit this message and tag you back : - )


Yesterday late evening I’ve got this small thought: What if PureOS “remaining updates” installed without using Ethernet connection (or something close to such procedure while …)? Therefore:
ls /lib/modules/$(uname -r)/kernel/drivers/net/ethernet/intel/e1000e. And if you get: e1000e.ko, Intel’s proprietary binary file, as answer please try:
sudo depmod -a
sudo reboot

If above doesn’t work for your fixed network connection, next step would/should (might help) be downloading of e1000e-3.8.4.tar.gz:
tar zxf e1000e-3.8.4.tar.gz
cd e1000e-3.8.4/src
sudo make install

Just my coarse guide/direction, it is up to you (likely related to Elvis Presley song: “Only you”) to find exact way out, actually way toward Ethernet-enabling over there.

1 Like

Thank you! I managed to install LibreWolf (although it failed yesterday, so I wasn’t counting on it), but unfortunately there is still a problem with Ethernet.

I have got “e1000e.ko” and did a reboot but nothing changed.
I then downloaded the e1000e-3.8.4.tar.gz file from the official site and had some problems during installation.

Although it comes out that PureOS is now too difficult for me, I’m so glad that I was able to solve these few problems with your help! : - )
At this point I will probably try a few other Linux distributions, but I will keep in my heart what I have learned so far.

And there is a also a screenshot with those errors:

Thank you so much again and have a great Tuesday and Wednesday in peace and joy!

1 Like

Please have a bright day too! And hope you’ll come back to use PureOS 11, if not earlier, perhaps by using another laptop with another Ethernet hardware. Although, similar add-on device with USB-A male connector might be your choice as of tomorrow, should work with PureOS Byzantium installation out-of-the-box (as I’ve already found this out):

And, if allowed, I’d just like to repeat here this recent and very kind advice, that I’m finding very important:

… as you already do consider …

Sounds good, thank you as well! This is/was good move of yours (IMHO).

1 Like