ME: FW Partition Table: BAD


#1

On a Librem13v2 I’ve flashed 4.8.1-Purism-3, after it said the checksums were correct. Following https://puri.sm/coreboot/ I then ran cbmem -c | grep ^ME to see the output, and I don’t get the output listed. I get more worrying output. Should I be worried?

ME: Host Firmware Status Register 1 : 0xFFFFFFFF
ME: Host Firmware Status Register 2 : 0xFFFFFFFF
ME: Host Firmware Status Register 3 : 0xFFFFFFFF
ME: Host Firmware Status Register 4 : 0xFFFFFFFF
ME: Host Firmware Status Register 5 : 0xFFFFFFFF
ME: Host Firmware Status Register 6 : 0xFFFFFFFF
ME: FW Partition Table      : BAD
ME: Bringup Loader Failure  : YES
ME: Firmware Init Complete  : YES
ME: Manufacturing Mode      : YES
ME: Boot Options Present    : YES
ME: Update In Progress      : YES
ME: D3 Support              : YES
ME: D0i3 Support            : YES
ME: Low Power State Enabled : YES
ME: CPU Replaced            : YES
ME: CPU Replacement Valid   : YES
ME: Current Working State   : Unknown (15)
ME: Current Operation State : M0 without UMA but with error
ME: Current Operation Mode  : M0 without UMA
ME: Error Code              : Preboot
ME: Progress Phase          : <NULL>
ME: Power Management Event  : CM0PG->CM0
ME: Progress Phase State    : Unknown phase: 0x0f state: 0xff
ME: Power Down Mitigation   : YES
ME: PD Mitigation State     : Issue Detected but not Recovered
ME: Encryption Key Override : Workaround Applied
ME: Encryption Key Check    : FAIL
ME: PCH Configuration Info  : Changed
ME: Firmware SKU            : Unknown (0x7)
ME: FPF status               : fused
ME: Host Firmware Status Register 1 : 0xFFFFFFFF
ME: Host Firmware Status Register 2 : 0xFFFFFFFF
ME: Host Firmware Status Register 3 : 0xFFFFFFFF
ME: Host Firmware Status Register 4 : 0xFFFFFFFF
ME: Host Firmware Status Register 5 : 0xFFFFFFFF
ME: Host Firmware Status Register 6 : 0xFFFFFFFF
ME: FW Partition Table      : BAD
ME: Bringup Loader Failure  : YES
ME: Firmware Init Complete  : YES
ME: Manufacturing Mode      : YES
ME: Boot Options Present    : YES
ME: Update In Progress      : YES
ME: D3 Support              : YES
ME: D0i3 Support            : YES
ME: Low Power State Enabled : YES
ME: CPU Replaced            : YES
ME: CPU Replacement Valid   : YES
ME: Current Working State   : Unknown (15)
ME: Current Operation State : M0 without UMA but with error
ME: Current Operation Mode  : M0 without UMA
ME: Error Code              : Preboot
ME: Progress Phase          : <NULL>
ME: Power Management Event  : CM0PG->CM0
ME: Progress Phase State    : Unknown phase: 0x0f state: 0xff
ME: Power Down Mitigation   : YES
ME: PD Mitigation State     : Issue Detected but not Recovered
ME: Encryption Key Override : Workaround Applied
ME: Encryption Key Check    : FAIL
ME: PCH Configuration Info  : Changed
ME: Firmware SKU            : Unknown (0x7)
ME: FPF status               : fused

What should I do to get Qubes 4.0 working on my Librem 15v3
#2

Ah. I found the answer. It’s supposed to look like that with librem13v2.

https://puri.sm/posts/deep-dive-into-intel-me-disablement/

via


#3

FYI, I wrote that up in the Tracker here. I wondered too when I saw the difference, disclaimer notwithstanding.