Microphone on Librem 13v2 not recording in Debian or Qubes


#1

I’m unable to detect or record audio input on my Librem 13v2 under Debian Stretch (9 / stable) and Qubes 4.0. I’m running a recent coreboot build (one after the CPU overheating issue was fixed). I have toggled the microphone / webcam kill switch a few times to check this, and the video camera works.

I’ve tested this under Linux kernels 4.9 (Debian Stable), 4.16 (Backports to Debian Stable), and 4.14 (Qubes 4.0). I’ve tried following the directions in Microphone location and audio difficulties in librem13-v1 and https://tracker.pureos.net/T285.

What else should I try / check? I’ve poked around at ALSA and Pulse Audio controls and tried every iteration against Audacity and Gnome Audio Recorder.

Thanks for any help / suggestions!


#2

My microphone also stopped to work. When recording sound there is just noise and click sound on webcam/mic switch on and nothing on switch off. It looks like the cable is broken somewhere. Maybe around display hinge?


#3

Please contact technical support.


#4

Done - thanks - I was hoping this might be an easy-ish software fix.