Microphone on wired headset not recognized by librem 5

I tried plugging in my wired headset (normal headphone jack) and the phone doesn’t see the headset in the sound settings for input. Output works fine.

I was under the impression this was suppose to work now from https://source.puri.sm/Librem5/linux/-/merge_requests/583

Does this work for anyone else?

Yes, it’s supposed to work - with a caveat that it won’t work if you plug it in very slowly (a detection is triggered by insertion event, but if you plug it in slowly headphones may get detected already before microphone ring makes contact), and it won’t work if you have a switch that disables the microphone on your headset engaged (you’ll have to unplug and plug it back in with it disengaged for it to be detected).

1 Like

Definitely not a slowness of insertion issue. Validated that my librem5-base package is in tack(dpkg --verify librem5-base). Any way to test to see if it’s a hardware issue? Don’t think I’ve ever had a computer’s headphone jack fail partially before.

If not I’ll reach out to support. Feel bad poking them as I expect they are swamped with new user questions/issues right now.

I’ve tried at least 5 headset (all different brands) with the jack, works fine

Does your phone have the latest updates ? (this functionally works since a long time from now)

1 Like

I’m running byzantium. kernel 6.2.13pureos3 librem-base 61pureos1 (just got that one today)

Everything says it’s up to date

And for fault isolation purposes you would want to verify that the microphone part of the headset works when plugged into another computer.

You may also want to make sure that the headset you’re plugging in uses AHJ/CTIA TRRS standard (with mic at the sleeve). Librem 5 does not support the less common OMTP standard (with ground at the sleeve), so for those headsets you’d need an adapter. Apparently Apple had its own incompatible connection system too - something to keep in mind.

Both headsets I have work fine on my laptop.

This is the one I’m mainly trying to use: https://www.amazon.com/gp/aw/d/B0BM4HGSFJ?psc=1&ref=ppx_pop_mob_b_asin_title

Some research shows that one can’t really tell the difference between these connectors by looking at it, and there’s writing on it.

Even with the wrong type wouldn’t the librem 5 still detect the mic and just get feedback from it?

No, that’s not how it works.

I think that is correct - so you would need to ask the seller to clarify which standard, if either, it implements (if that information is not available in the blurb that came with the item).

Headset mics work fine for me. When I use a splitter to connect to my car stereo and a wired mic, it stopped working a few months ago. Used to work fine. Verified this with multiple cable/splitter/mic sets.