Mini cryptsetup: ERROR: luks-

I setup my new Mini by booting it and creating 2 users. I created a disk password at the beginning. Ran it for a day (both users), shut it down to relocate it (unplugged). When I plugged it in and rebooted, I was greeted with this error message in the title and "Please unlock disk luks-…

I’ve tried the password I created several times, tried rebooting, but no joy. I’m at a loss. What did I do wrong?

just a theory: your keyboard is not US therefore you use a different one while being inside your Desktop Environment whilst your grub is set to the US keyboard. Meaning, if you use the letter z in your password, it is replaced with y on keyboard while it asks you for the password to put in. This works as long the language you use doesn’t have any other letters than the US keyboard would support.

try $ locale -a to see the language the system is using (its
en_US.utf8 by default)

you could change that by $ nano /etc/locale.gen

and change the set language to the one you are using inside the Desktop Environment, like $ sudo locale-gen the_language_you_use_inside_your_DE