Mini - Display Port Seems To Turn Off Randomly And Back On Again

IDK what is causing it but, it is annoying. Is this a known issue? Is there a known workaround?

I appreaciate any help.

Do you see anything with the sudo dmesg command in a terminal that explains why DisplayPort is turning on/off? Also what monitor are you using?

1 Like

Thanks for your reply. Let’s see here, I will answer the easy question first. I am using a Sceptre C35 ultrawide 35 inch 21:9 @ 100hz/1440p. I cannot recall seeing this happen when using hdmi cable for the other 21 inch asus craigslist monitor I paid 25$ for two years ago.

And for the more complex answer, I do see some bold black texts, and bold red text, issued as warnings or failures. I will copy all highlighted text and paste here.

From top to bottom:

0.042479] DMAR: [Firmware Bug]: No firmware reserved region can cover this RMRR [0x000000009b000000-0x000000009f7fffff], contact BIOS vendor for fixes
[ 0.042482] DMAR: [Firmware Bug]: Your BIOS is broken; bad RMRR [0x000000009b000000-0x000000009f7fffff]
BIOS vendor: coreboot; Ver: PureBoot-Release-17.1; Product Version: 1.0

0.672872] DMAR: Translation was enabled for dmar1 but we are not in kdump mode

0.854722] nvme nvme0: missing or invalid SUBNQN field

0.923445] i915 0000:00:02.0: firmware: failed to load i915/kbl_dmc_ver1_04.bin (-2)
[ 0.923448] firmware_class: See for information about missing firmware
[ 0.923450] i915 0000:00:02.0: Direct firmware load for i915/kbl_dmc_ver1_04.bin failed with error -2

2.269124] librem_ec_acpi: loading out-of-tree module taints kernel

56.169785] systemd[1]: /lib/systemd/system/plymouth-start.service:16: Unit configured to use KillMode=none. This is unsafe, as it disables systemd’s process lifecycle management for the service. Please update your service to use a safer KillMode=, such as ‘mixed’ or ‘control-group’. Support for KillMode=none is deprecated and will eventually be removed

58.547579] r8169 0000:01:00.0: firmware: failed to load rtl_nic/rtl8168e-3.fw (-2)
[ 58.547584] r8169 0000:01:00.0: Direct firmware load for rtl_nic/rtl8168e-3.fw failed with error -2
[ 58.547586] r8169 0000:01:00.0: Unable to load firmware rtl_nic/rtl8168e-3.fw (-2)

217.085683] i915 0000:00:02.0: [drm] ERROR CPU pipe A FIFO underrun

Edit: When making this post, I had several blackouts and even the machine froze for a second. I am just using LibreWolf to make this post and have a single terminal open. Resources say hardly anything is being used, 1.5 gb ram used, 1-3 % cpu used.

Yesterday was the first time using DP thus when I noticed the blackouts. Comptuer ran fine however despite this blackout occurring randomly every half hour or more. This morning, the system took forever to get past encryption, and log in to PureOs was delayed by a few minutes as well. There was more blackouts this morning writing this post than in 4 hours of use yesterday. IIRC I had 6 - 8 blackouts in 5 minutes while making this post. Comptuer is resting on a metal surface helping wick away heat, otherwise my room is rather cool. Computer feels cool to the touch and the fan is working blowing warm air out, not hot air.

I cannot think of anything else to mention at this point. I am using the DP cable that came with the monitor, though I couldn’t tell you if its a DP 1.0 or 2.0 or however many rev there are.

I am a little concerned with the results of that command you gave me as it mentions some issues I do not undertsand. So I have more learning to do today :slight_smile: which is good. But I would like to see this little Mini last me, hope these issues can be resolved.

Thanks for any help and guidance provided. If you want me to post the entire return on command, mention so, as long as there is no identification info in the reply I will do so here. Or else I can send in a private message? Let me know what else I can do to help you help me.

Just as a trouble-shooting step, what happens if you turn the resolution down on the monitor? Does it continue to blink on and off?

1 Like

I just read your post and adjusted the monitor resolution down to 1600x900. I will see if there is any blackouts and report back.

That was quick. I still get the black outs. No change. In the meantime I have swapped back to a nice and comfy HMDI cable.

Hmm… my Mini is connected via Display Port to a 34" Dell monitor, running at 3440x1440 (21:9). I am only running @ 60Hz though, not 100.

When I had hooked the same monitor up through the HDMI port, it started blinking after 10 minutes or so. When I hooked it up to the Display Port, it worked perfectly.

As another test, you could also try turning down the refresh rate to see if that makes a difference.

1 Like

I was just thinking that. IDK I should check but I think I have freesync enabled as well on the monitor? So yea, this is prolly easy to solve. Thanks for helping me out.

I am still concered with the results though with that sudo dmesg command.

I’m guessing that this means that there is some problem in Purism’s BIOS that it isn’t handling Direct Memory Access Remapping (DMAR) correctly. You might try turning off VT-d (if it is enabled) and if you have another DisplayPort monitor available, you might try that to see what error messages you get, but I’m guessing in the dark. This is really a question for @MrChromebox or Purism support.

it’s actually a kexec issue, but should be resolved in Pureboot 18.1

1 Like

No big deal then. :slight_smile:

I set my display to 60hz, and I notice it less now. Helps if I don’t full screen.