Mobian+phosh on pine modem disconnect in deep sleep/sim pin dialog keeps popping


i’m digging further in the linux phone world, been trying using my phone sim card for real world use.
this is on a pine dev edition (messing about while waiting for my librem ^^) with mobian installed

something i’ve noticed is that after the phone is in sleep for a while (prob entering deep sleep mode) the modem seems to disconnect (icons go away no provider listed etc) and when i power it up the sim unlock dialog pops again and after that the modem seems to connect to the telecom network again (at least the UI makes it look like this)

is there a way to have the phone remember the sim pin (the device is encrypted and password locked anyway)? and to keep the modem online?

for this behaviour has me wondering if i can receive calls/texts in this state and you kind of don’t want to miss that 1 vital call when there is a need for relatives or other important persons to get in touch with you.

any thoughts or help would be most welcome!
i want to get to a point where i can trust linux phones for the important stuff so i can ditch the android phone :stuck_out_tongue:


You may be able to prevent the modem from disconnecting by adding a udev rule as described in

Not sure about the SIM PIN. It may be a moot point if the above keeps the modem from sleeping.

As of the last time I was using the Pinephone’s calling ability (November 2022) on Mobian, the modem would reliably wake up from suspend for phone calls and texts. This was with the open source firmware from the git repo linked above.

thanks for the answer I’ll check that out!

ok replied to early i mixed my posts in various topics, dove a bit further in this and found the file it’s not quite the same so i need to dig a bit deeper

This does seem to keep the modem on, but it still seems to asks for the sim pim. looks like the modem displays on but not connected (strike through) in that case

i’ll test a bit further

Ok maybe something went wrong, but the solution from jt0 seemed to work

my file was slightly different i changed the lop of the file below # Default attributes values to

LABEL="eg25_start" ATTRS{idVendor}=="2c7c", ATTRS{idProduct}=="0125", ATTR{power/control}="on" ATTRS{idVendor}=="2c7c", ATTRS{idProduct}=="0125", ATTR{power/autosuspend_delay_ms}="3000" ATTRS{idVendor}=="2c7c", ATTRS{idProduct}=="0125", ATTR{power/wakeup}="enabled" ATTRS{idVendor}=="2c7c", ATTRS{idProduct}=="0125", ATTR{power/persist}="0"
ATTR{power/control}="on" was auto like in the original solution post above

havn’t seen the pin request anymore, phone seems to connect calls after a night on my nightstand so much better ^^

1 Like