Mobile data not working on Librem 5

I’m using a Librem 5 with AweSIM, and I haven’t been able to get mobile data to work. Calls and texts do work. I’ve turned on Mobile Data in Settings, but I don’t know if more configuration is necessary. “Access Point Names” looks important, but I don’t know if or how that’s related to the problem.

1 Like

Hello, can you send a picture of your current APN settings?

This screenshot looks different from usual. Usually, it just shows two options: No Broadband, and no duplicates.

i find
it may help. i got some problem before.

1 Like

:confused: It looks like there’s not much information there. Also, the Broadband option is now missing again from the list.

But did you turned on 2G, 3G, 4G (Preferred) :white_check_mark:, any other that is Preferred or just 3G Only (as 3G is what I see within screenshot of yours above) within Settings Network Mode? Why not 4G, is it reachable from the place where you use your phone? Perhaps not about helping much, just curious as your problem might be related to, but not sure, your 3G mobile data not working (why particular BM818-A1 4G band from B2/B3/B4/B5/B12/B13/B17/B25/B26/B66 isn’t reachable)?
EDIT: Besides Wi-Fi is on, turn it of please, should help with getting answer to your question.

Yes, I don’t think I’ve ever switched it away from that.

I do turn off Wi-Fi (with the hardware switch) when I experiment with the mobile network settings and whenever I leave the house.

1 Like

just FYI if you set the network selection on manual for the lowest available (mine is 2G) in your cellular network settings you will have the best VOICE signal indoors :mask:

5G is basically unusable from the inside (unless the modem switches to some lower frequency in the outgoing radio spectrum)

I just found out (although living in Europe) that att.mvno and tfdata conflict each other and therefore might help you to find the way how to (re)solve this issue of yours. “If your APN is att.mvno you will be able to access the internet using your cellular data connection.” Also: “When your APN is tfdata your cellular data connection, MMS picture messages, and group texts work automatically.” Perhaps below (and other similar links) help further (but I don’t think that some changes will be needed under current Settings, other than switching your APN to tfdata):

I switched to tfdata a couple weeks ago, and there’s been no change.

The only fields I see when making a new APN are Name, APN, Username, and Password, so I can’t put in all that information that appears in those links.

I tried sending a text as mentioned in the link, and I got back “Service not available”.

I’m aware of this fact. But anyway and therefore still hope that someone using T-Mobile or AT&T backbone (with Librem AweSIM) should help you (soon). Or better, go ahead and contact Purism support team directly. Perhaps consideration of using T-Mobile backbone in area where you live sounds good … yet AT&T backbone, as in your case scenario should be fully functional as well (cannot be that you are not able to get mobile data, over 4G, working with your L5, especially when certain monthly amount already payed for this particular service).

1 Like

For your carrier try these APN settings:

Name: Default
APN: Phone


Looks like that fixed it. Thank you. :grinning:

Did not work for me using AT&T and Awesim. Either 3G only setting for calls or 3G, 4G referred, or 4G only for data. All other options create a modem error, which doesnt like or cant handle configurations like (3G, 4G).