Modem woes and reliability

I have done a modem update, but I still experience modem troubles of the kind mentioned above. Of course waking up from suspend is a tall order, as is the switching of cell towers (specially when crossing a border) - often it even looks like it is online untill I try to watch a website or read my news feeds.
It is not enough to switch back to my windows phone (just yet), but it does give you that nagging feeling you might be missing important calls or messages. And it is just very annoying to keep seeing those ‘you are offline’ (Newsflow) or ‘error loading the page’ (Angelfish) messages.

1 Like

Try the bm818tool…

Indeed that nagging feeling is the core of my post. I don’t trust this phone to work when it’s most important and i’ve come to the conclusion that that is a no go. Because calling/sms/receiving is still the most important thing about a phone for me.

Yesterday i actually though: why not get one of these cheap nokia flipphones which doesn’t do a lot but call ^^

I think i disabled auto suspend again because it made the librem5 a bit more stable. also i usually run around with both mic and wifi killswitches on off.

1 Like

See this memento of a sadly gone webpage: Librem 5: A to Z – linux phone guides - search for BroadMobi. I definitely recommend doing it, with my (got it in early 2021) Librem 5 it was a night and day change.
The other way is to install the bm818-tools package, that then will add a launcher called ‘BM818 tool’, but you definitely will have to contact support to get newer firmware.

I have also experienced these same issues and put my SIM back into my iPhone to get reliable phone service. Additionally, when I turn on Mobile Data, it drains my monthly allocation in one to two days. I tried everything listed in this forum with no improvement. I updated the modem but the bm818-tool shows that sometimes it can find the FW version and other times it cannot (with the SIM put back into the phone, with the kill switch on or off, the FW output is inconsistent.) I emailed support and they are helping diagnose the problem and provide a solution.

1 Like

I’m wondering if you also loose the mobile data connection when calling/SMS-ing does not work any more. I do not call/SMS often, but I notice that the mobile data connection is quite unstable for me.
I use these commands now to reset the modem. Usually only the first command already brings back the mobile data connection. Using these commands prevents me wearing out the kill-switches. And actually, I think they work better than flipping the kill switches.
Thanks for the post. Very useful for getting the priorities right.

1 Like

i’ll have a go at those commands next time it dies. that might be a workaround for when i need to use the phone asap

i havn’t seen this personally, but i don’t use data a lot. Only had it once but then i was watching twitch on the librem

i have firmware

m100E_YCSN0_1.0.0_220926
YCSN0_M100E_1BAD_3117_V1.0.0.2_20220930
M100E_1.0.4_200715

is that the latest or is there a newer version? because it looks like 2022 software

If it helps, I updated my firmware to:

M100E_YCSN0_1.0.0_220926
YCSN0_M100E_1ACD_B325_V1.0.0.2_20220930
M100E_1.0.4_200715

1 Like

thanks seems i’m running the latest. Support also confirmed that.
Going to take the steps i got from support.

But this sort of supports my post, we are running the latest. but the modem is stil pretty unstable. firmware seems to be from at least a year ago

that sort of supports my feeling that it doesn’t get the priority it should get. Maybe the work needs to be done outside the firmware, i don’t know i haven’t delved into the nuts and bolts.

Also the latest update i pulled saw the mobile settings app getting updates (in example). Which is nice, but not critical to the base functionality of a phone.

Like i stated before: i would not trust the librem5 with my life nor with receiving critical calls. That is something i never had with a phone, and i still trust my 10year old windows phone.

that is the problem with the linux phone space at the moment. I really hope that can be fixed because at least for me, that is the 1 critical issue keeping the linux phone space from becoming my dialy trusted device

1 Like

I just got mine back from repair. It was wiped of course but now I’m having all kinds of trouble with the modem and wifi. I was able to connect to my provider yesterday, but today in no ways of trying I cannot connect at all in fact it’s trying to connect to other carriers not mine. I confirmed that my SIM works in my Samsung phone so has nothing to do with the provider. Also the WiFi is now anoyingly randomly shutting down and not reconnecting for some reason. I love this phone but like you this part of it needs top priority all hands on deck to try and solve.

Did they replace the modem? (so that the IMEI changed)

Updating to the latest Redpine firmware solved my WiFi problems.

For the modem problems, I created a script at /usr/local/bin/resetmodem with the content:

mmcli -m any --reset
service NetworkManager restart

I made it executable: sudo chmod +x /usr/local/bin/resetmodem

Then I execute sudo resetmodem from the terminal. I’m thinking about setting it up as a cronjob and executing it every couple hours.

1 Like

I believe they did but my phone was working fine the first day I got it back, so not sure it matters. Also with my provider (who I actually work for) I’ve changed my SIM into different phones many times without issue.

Also why is it I can’t select a network manually in the settings app? Should it not display all the available networks?

I have a sparklan card.

I have been wondering about this too.

I tried doing this with the command line as well and it does not reveal the available networks with a scan. Which makes me wonder how it even finds networks. I’m having a very weird problem with my phone. So it registers with the network in town where I work but as I travel home about 50 km away it loses registration even though it is still on the home network or should be. My SIM works fine in other phones so it’s definitely the L5. The errors I’m getting in the journalctl is “reject cause: roaming-in-location-area-not-allowed” and “ps-services-in-location-area-not-allowed”

It doesn’t make much sense to me because the phone works in one area but not another? The same network is available but the phone thinks it’s roaming I think. When it’s searching for an operator it gives errors “Current operator MCC/MNC is still unknown” which makes no sense because it works in town but not at home. I also tried enabling roaming and that didn’t help either.

Does anyone have any ideas what could be going on here?

Today, again, out shopping, I had to HKS the cellular modem to be able to check something online - leaving me to wonder how long I had been online by that time.
I get the impression it has something to do with switching antenna’s. (Just a stab in the dark.)

All and all, this happens too often, and it is becoming an irritant. Pioneering the L5 is an adventure, but it would be nice if the absolute basics (the phone bit) would have been covered by now.

Yes! Also bloody annoying: every single time you reset the modem, the yellow exclamation mark pops up, and you have to disallow/allow the roaming option in the settings.