Three issues bothering me right now: poor call audio, mobile data failures, misleading battery percentage

I tried that now (using “gnome-sound-recorder”) and there is a background static noise, as if the microphone volume is too high. Looking at sound settings, there are three different choices for “Input Device”:

  • Handset Microphone - Built-in Audio
  • Stereo Microphones - Built-in Audio
  • Analog Input - Modem

I wonder, is the “Analog Input - Modem” the one that will matter for a phonecall?

Anyway, I never changed any of those settings since I last reflashed PureOS. All three microphone volume settings are set to the maximum. I have been hoping that using the default settings would be good.

Since quality is good for you, could you check what the microphone volume settings look like in your case?

Also, is VoLTE enabled?

No, I don’t think so, at least I did not do anything to enable it. Do you mean that having VoLTE enabled would be good or bad, regarding phonecall audio quality?

This indeed helped, thank you!

I have kept it plugged into the charger most of the time, so my case fits with what you described.

I used to get complaints about there being an echo. Lowering call volume (or using a headset) helped.

Could you explain exactly what you mean by “Lowering call volume” hare? Is that in sound settings, under “Input”? If so, which “Input Device”?

Mobile data connection suddenly stops working.

Is toggling the HKS not enough?

That can also work, however I much prefer to have a software solution, not involving the HKS. Most importantly, the bug(s) causing the issue should be found and fixed. I have been trying to debug the issue myself, but have not gotten very far with it yet. Not sure if things go wrong in the kernel (in which case we can fix it) or inside the closed-source modem firmware (in which case nothing can be done, I guess). One thing I aim to try to test is to use a different modem and see if the issue still appears then.

Where is the VoLTE enabling to be found? I cant find it.

So far my only lip biter is the Battery endurance. 7am-7pm it goes from 100% to 17% …with the unit HK switches in the off position and nothing enabled.

Thanks, I did this now after saving the old settings somewhere, the files were recreated after reboot as you say, and I can see they are different. The two first microphone volume settings (“Handset” and “Stereo”) are no longer at maximum, insted they are at about 40%. I will make some calls and see if the audio quality is better now.

(Earlier I thought I had default settings but it turns out I did not. I fooled myselt because I had reflashed the phone, which did restore defaults, but then after that I restored my old ~/.config directory from a backup copy because I wanted to keep some other settings, not realizing that doing so also restored audio-related settings.)

The following commands seem to work, at least most of the time:

sudo mmcli -m any --reset
sudo service NetworkManager restart

So having a script that checks if the cellular data connection has stopped working and runs the above commands in that case, might work. (But still only as an ugly workaround since all ongoing connections are probably lost when that happens, not very nice.)


Thanks, something like this is what I was looking for. This resets the USB hub that the wifi and cellular radios are connected to, because when you run the script it will drop wifi as well.

Works well though, and using it instead of the HKS is what I would prefer. I also prefer manually triggering it, because there can be so fringe cases in which I wouldn’t want the script to fire.

1 Like

Here is a screenshot of my sound settings right now. I am not sure if this is the default or not

VoLTE will give better call quality as the bandwidth is larger. However, the source mic audio must be fixed first. Have you tried another recording after resetting to default sound settings?

@FPJ you can install bm818 tools to enable VoLTE
sudo apt install bm818-tools


Thank you. Have a great weekend and be safe.


Could you explain exactly what you mean by “Lowering call volume” here?

I meant pressing the buttons for “volume down” during a call so it is not at 100%.
This already reduced complaints about echo A LOT.

Extra data point: I found call audio quality to be best when using headphones.

1 Like

Just wanted to say that this script is exactly what I was looking for. It works consistently. It doesn’t drop the SD card either, I think. I might be wrong.

But this is faster and easier than using the HKS.


I have been struggling with battery calibration for as long as I can remember, even when making a point not to charge the phone until it is close to empty. Seems the calibration continues to drift higher than the energy-full-design value in most cases anyway, as described in this post.

Doing complete drain/reharge cycles is very impractical with a phone where battery usually doesn’t last a full day, so is also constantly carrying a power bank.

For me, no calibration (i.e. after reinserting the battery) is better than the inevitable calibration drift that overestimates the remaining battery life. I think this is true for many L5 users, as I often read about the L5 battery going from 30%/40%/50% to zero in a matter of minutes.

Thanks for this post @Skalman. It think that posts like this are very important for Purism to set the priorities.


Thanks, I marked your answer as “solution” because you summarised so nicely. However the data connection distruption issue is not really solved.


See for more info: Mobile data stops working, outgoing packets still sent but incoming packets no longer arrive (#328) · Issues · Librem5 / OS-issues · GitLab

In short: to make the mobile data connection stable do:

sudo -i
echo 5000 > /sys/devices/platform/soc@0/38200000.usb/

This seems like it could be the missing link! This should be getting trumpeted to all L5 users! I mean I get that it is a work around for another bug but if it works it will be glorious. I made the change and will report back my experience!

1 Like

At @janvlug link, @dos says, “Please report your findings at 1s. I’d like to avoid going back to 2s if possible, the difference in power consumption when the hub is active is quite big”, implying a power penalty. The suggestion here is to use 5 seconds.

I can report that even using 1s the power drain is significant. Just consider that if the default value is a half second (500) then by increasing that to a second, you are doubling the amount of time it can theoretically be active after idle.

Still this is a great development because it shows that the problem has been identified and work can continue on a real solution.

regarding the network dropping, does anyone know if it happens to correlate with enabling the toggle for “mobile broadband can be disabled to save power” from the power menu? Cause if the screen is off for an extended period of time, it seems like that disables the modem, only for it to reconnect when you use it again.
Edit: nevermind, this seems to specifically refer to the issues where it cuts out while being used. apologies.

No you are on to something. Power savings on the usb hub is the issue here. What is happening is that the default settings causes a bug to service which makes the cellular connection go stale. This is alleviated by raising the idle time, but has the negative effect of increased power consumption, and it is significant. However, this is just a work-a-round to not trigger the bug. It is not the real solution. But I guess if you are in a place where you really need a stable connection, you can just change this setting, and then when done revert back to the default value for power savings.

It does however work and work well.