Mouse not working after update/upgrade


#1

I did an apt-get update and apt-get install and my wireless and wired mouse no longer work.

I checked the gnome tweeks mouse setting but nothing seems to work.

thanks,
DCorwith


#2

This might not solve your situation, but it might. On 2018-05-18 I did an apt system upgrade that upgraded gnome-shell 3.28.0-1+b1 to 3.28.1-1. After the update my mouse & trackpad could move the cursor but I could not click anything. Very annoying, because I then had to use keyboard shortcuts to do everything until I discovered the problem: the shell extension “Workspaces to dock”. It turns out to be a known issue. I turned it off, logged out and back in, and mouse/trackpad clicks worked again.

I hope that’s all it was for you and that this saves you the hour it took me to track it down.


#3

Thanks for the reply. I checked and workspaces to dock is not installed. Any other ideas folks?


#4

Hi @dcorwith, check to see if you have any other GNOME shell extensions installed and activated, particularly ones that did not come pre-installed with your Librem laptop. The pre-installed extensions will be the ones that you can’t uninstall from GNOME Software (they don’t even show up there as being installed - a very messy situation at the moment).

I’ve read elsewhere that many, if not most, GNOME shell extensions are not even tested against GNOME shell updates, which means that another shell extension might be causing your issue. Please let us know here if you discover this.

By the way, do you get any mouse movement, or do you get what happened to me, which was OK mouse movement but no mouse clicking?

Cheers!


#5

No mouse movement at all. Here is the reboot info:

  • Press SHIFT key during boot to get the GRUB menu
  • Select Advanced Options
  • First kernal with recovery mode ver 4.14
    On boot when I plug in the mouse it recognizes it and gives me a report something like:
    BRLTTY 5.6 Linux screen driver…
    usb 1-5 new low-speed USB device…

when booting into the crypto set it continues a normal boot and the mouse doesn’t work at all. I tried several mouse and several usb ports on laptop. I’m fairly sure it’s a software/firmware

When using GRUB to select the previous kernal 4.13 it doesn’t work either.

any help would be appreciated


#6

I’m guessing your wireless mouse uses a USB receiver? Have you tried any other USB devices (like external hard drive or whatever else) to see if they work? Just wondering if it’s a USB problem or is restricted to mice.


#7

I just flashed my librem13 and learned that the F1 key toggles the touchpad. Not sure it will answer your issues but thought I would mention it.


#8

OP didn’t say if they had a Librem 13 or 15. Not sure how it is on the Librem 13 (because I don’t have one), but on my Librem 15 v3 the F1 key starts GNOME Help (yelp) and Fn-F1 toggles the trackpad. The F1 key has two icons side by side on its lower right: a mouse with a slash through it and a mouse, and the two icons are separated by a vertical bar. Fn-F1 has no effect on any wired USB mouse that’s plugged in, but I don’t know if it has any effect on a Bluetooth mouse. I also just noticed a Bluetooth icon on my F12 key, so I would expect Fn-F12 to toggle Bluetooth.


#9

This is a Librem 15v3
I tried the Fn-F1 key that has the mouse icon. No affect at all. The other Fn keys work ok. Not sure if the Fn-F1 even is configured?? Maybe Purism can answer that.

  • I have tried two USB mice, no luck. Always worked flawless before the apt-get update and upgrade

  • direct wired mouse (via USB) doesn’t work however it is recognized in the bootup process as noted in a previous post.

  • Frustrating not having my mouse which is about as basic as it gets on a computer.

  • Ready to install Ubuntu. How do I encrypt the drive and reinstall multiple OS to use the GRUB? Repartition and start over? I’m ready…


#10

On my Librem 15 v3 the Fn-F1 toggled the trackpad from day 1. No configuration has ever been necessary, and Fn-F1 overrides the GNOME Settings if the trackpad is set to “On”.

Sounds like time to contact Purism directly. Good luck!


#11

7 months w/o a mouse and I finally fixed it almost. Posting so others can fix theirs with this obscure solution that works.

  • So I originally asked for a boolean that must have been turned on/off on an update that disabled the mouse. Here it is:
  • Purism OS installs “USBGuard” to prevent unauthorized usb devices from rogue attack. It does this by whitelist/blacklisting the devices. Well it somehow disabled my usb devices completely.

See the article:
https://www.kernel.org/doc/Documentation/usb/authorization.txt

How to turn your mouse back on:
I think the USB Guard program was uninstalled and left the USB devices “unauthorized” (authorized = 0) in a a text file(s) located at:
/sys/bus/usb/devices/DEVICE/authorized
where DEVICE = usb1 etc. use Space FM or Nautlis to see the directory and then change the authorized text file with the following command:

sudo nano authorized

  • change it to 0 to 1. Ctrl-O to save and Ctrl-X to exit nano
    ALSO check the drivers sub directory:
    sys/bus/usb/drivers/usb/1-4/authorized where 1-4 is the bus nbr from the command > lsusb
  • sudo nano authorized

  • change this to 1 and save as well.

/sys


#12

Now on reboot, the “authorized_default” is set to 1 but a reboot resets this to 0 so a manual resetting of “authorized” boolean has to be done.

Question:
HOW DO I RESET THE Authorized_default to 1 on boot? So the usb ports will automatically work on boot?
thanks!


#13

This is a USBGuard issue: The following will reset your mouse:
To allow a device to operate, run the following:
Step 1: Plug in the usb device (mouse, memory stick etc)
Step 2: Show the listing of devices USBGuard is controlling. Note the “allow id” or “block id” in the list and it’s number (1, 2, 3, 4 etc)
~$ sudo usbguard list-devices
This will list devices on your computer
Step 3: Now allow the device with the following command
~$ sudo usbguard allow-device 4

To see a list of commands simply type:
~$ usbguard

See the man pages for details how to reset your policy:
~$ man usbguard
look for “generate-policy” command

Hope this helps someone else with a similar problem