Multiple Librem5 issues

Hello, I 'purchased a librem5 back in 2021, so I’ve taken a while to post this to hopefully get some help,
So I have a few issues and i would love to resolve them so I can use my librem5 much more, the first most irritating issue is the @ simply does not work specifically and only when trying to enter an email address to sign up or log into a site(typing an @ works fine any other time), this is obviously a massive issue preventing me from using this phone much, I’ve been hoping a update would fix this but 2 years on and no luck, one way to workaround is typing my email address into a blank text document and then copy past it into the email field, however this doesn’t always work sometimes no matter how i try it simply will not paste into the email address field there is no work around i have found.
Currently about for the last month I have suddenly become unable to download/install any OS or software updates for the phone if I connect to the internet and go to the main software/update store the phone immediately shows some kind of error which is displayed over the update button so simply cannot get any updates, if I connect to a vpn suddenly I can download updates, but after 10-15min it will show an error again, this has been happening for about 1month now.

And lastly as well as the recent and current update issue I can no longer load any webpages regardless of which browser I use and regardless of using a VPN the phone has become unusable .
I would love to use this phone heaps more as i love it isn’t google, apple or samsung etc but the issues are small but impact my ability to use the phone so much that it’s just a brick, which is a shame.

if there are any way to resolve any of my issues please let me know.
P.s forgot to mention the camera doesnt work it wont even load it gives an error saying the camera isnt connected, it worked originally but after updates it just says li saya camera is not connected which makes no sense.

Could you provide more details? Where exactly does it not work? I’m using this phone since 2019 and I’ve never noticed @ not working anywhere (aside of Chromium/Electron, which has more input issues than that).

Same about the other issue - it’s hard to figure out where to start looking at from your description. Provide as many details as you can, this description doesn’t tell me anything about what’s actually happening.

Never encountered that @ problem either

For your update problems, you can try the following command in the terminal, it check for available updates :
sudo apt update
(it will ask for your unlock screen password, without printing it when you type it)

If no error occurred, apply the available updates :
sudo apt full-upgrade

Is this with Firefox?

You need to update date and time for certificates to work with the software store and to use the browser in any fashion.

I would start with posting the output from lsb_release -c

Maybe bad Javascript. You should tell us the URL for the web site that you are attempting to log in to.

the @ doesn’t work in any email field, regardless of the browser, firefox, chromium or brave any other key or symbol works but not @ it simply doesnt appear when i press the key , like i said i can sometimes type it into another field or text document and copy paste but that doesn’t always work

thanks but have already tried that it basically runs the command but doesnt update anything having an error says something about not being able to reach the server or something.

yes but also with any other browser, chromium, brave and the default browser that comes installed.

Is your Date/Time correct?
How were you able to install Brave and Chromium?

thanks, i’m not sure how to do that? here’s the error i fet seems to be flathub related

its applicable to any website

yes date/time is correct. I downloaded them before this issue happened. it only appeared about 1 month ago, before that i my phone was fine aside from camera not functioning and the @ issue.

sure what details would be helpful?

Open the terminal and enter this:

Anything that might be related. Here some examples (you can give further information if you think something may helps).
Do you still use PureOS Byzantium or any other system?
Did you change something on your system before bugs happened?
What layout do you use for on screen keyboard? Default en-us? Did you try a physical keyboard and does it work?
What errors (please type in instead of screenshots/photos)?

Even basics like “I’m using PureOS Byzantium” help us to exclude source of errors. Some information where already helpfully.

But first try to do what fsflover wrote above my post and give a reply if it works or not (with error message). It may already fix something for you (tell us what is fixed and what not).

Can you give the error given by apt ?
Because it’s the important part to solve the problem if this command fails

But from the screenshot you gave after, seems to me the phone is not connected to internet
When the phone is not connected to a network you should see this icon in the top left :
Next to the 2/3/4G icon or wifi icon

Do you see it ? Are you even connected with Wifi or Mobile data (2G,3G,4G)?
If you use a mobile data connection, can you test with a WiFi connection ?
If you use WiFi, can you test with a mobile data connection ?

You have no internet connection.

Thanks for the help everyone The issue seems to be the VPN, I was selecting the VPN from thr top pulldown menu which doesn’t seem to do anything, to solve my issue I have to connect to the VPN but have to load the VPN app and connect then all the internet and update errors go away and everything works normally. glad to have this fixed but not sure the point of the VPN icon from the top pull down menu as it doesn’t seem to actually connect the VPN…

1 Like